[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xbindkeys-devel] xbindkeys-1.8.3

From: Philippe Brochard
Subject: [Xbindkeys-devel] xbindkeys-1.8.3
Date: Mon, 18 May 2009 21:18:47 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.3 (gnu/linux)

From: Richard Zidlicky <address@hidden>
Subject: xbindkeys-1.8.3
To: address@hidden
Date: Sun, 17 May 2009 11:36:33 +0200
User-Agent: Mutt/1.5.18 (2008-05-17)


very usefull software, using it on Fedora 10, rpm built cleanly after instaling
guile-devel as 
  rpmbuild -ta tarball
Upon first startup

  xbindkeys --defaults > /root/.xbindkeysrc

did err out when there was no previous .xbindkeysrc*, however I can not 
it anymore. 
  xbindkeys -dg 
worked fine.

After a few days of use found one coredump:
#0  0x428e26e6 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x428e4158 in abort () at abort.c:88
#2  0x42920c9d in __libc_message (do_abort=2, 
    fmt=0x429fe5c8 "*** glibc detected *** %s: %s: 0x%s ***\n")
    at ../sysdeps/unix/sysv/linux/libc_fatal.c:170
#3  0x429270f5 in malloc_printerr (action=2, 
    str=0x429fb488 "free(): invalid pointer", ptr=0x8052860) at malloc.c:5994
#4  0x42929146 in __libc_free (mem=0x8052860) at malloc.c:3625
#5  0x43fb616c in scm_gc_free () from /usr/lib/libguile.so.17
#6  0x43ff271b in scm_i_stringbuf_free () from /usr/lib/libguile.so.17
#7  0x43fb6f3b in scm_i_sweep_card () from /usr/lib/libguile.so.17
#8  0x43fb559d in scm_i_sweep_some_cards () from /usr/lib/libguile.so.17
#9  0x43fb57d7 in scm_i_sweep_some_segments () from /usr/lib/libguile.so.17
#10 0x43fb44d0 in scm_gc_for_newcell () from /usr/lib/libguile.so.17
#11 0x43ff182a in ?? () from /usr/lib/libguile.so.17
#12 0x43ff1864 in scm_i_c_make_symbol () from /usr/lib/libguile.so.17
#13 0x4400b673 in ?? () from /usr/lib/libguile.so.17
#14 0x43fe5b70 in ?? () from /usr/lib/libguile.so.17
#15 0x43fe4d47 in ?? () from /usr/lib/libguile.so.17
#16 0x43fe5860 in ?? () from /usr/lib/libguile.so.17
#17 0x43fc9bfe in scm_primitive_load () from /usr/lib/libguile.so.17
#18 0x0804b7b1 in get_rc_guile_file () at options.c:857
#19 0x0804957c in reload_rc_file () at xbindkeys.c:468
#20 0x0804999d in event_loop () at xbindkeys.c:275
#21 inner_main (argc=1, argv=0xbfa9e604) at xbindkeys.c:134

Not sure what was the content of the rcfile at that time, so far unable to 

I noticed on other occasions that malloc()/free() are very touchy in Fedora 10,
many of my programs that worked for years needed fixes - the more frequent 
were freeing areas where the pointer pointed into the area rather at the start
or double freeing.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]