weechat-support
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Weechat-support] build failure on older Linux version


From: FlashCode
Subject: Re: [Weechat-support] build failure on older Linux version
Date: Wed, 15 Aug 2012 08:01:17 +0200
User-agent: Mutt/1.5.20 (2009-06-14)

On Tue, Aug 14, 2012 at 01:25:26PM -0700, Lonni J Friedman wrote:
> Greetings,
> I'm trying to build weechat-0.3.8 on an old Linux system with
> gcc-2.96, and 'make' is failing:
> #########
> Making all in core
> make[3]: Entering directory `/home/n/netllama/foo/weechat-0.3.8/src/core'
> gcc -DHAVE_CONFIG_H -I. -I../..
> -DLOCALEDIR=\"/usr/local/share/locale\"       -Wall -W
> -Werror-implicit-function-declaration -pipe -O2 -D_LARGEFILE_SOURCE
> -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -DHAVE_ZLIB
> -DWEECHAT_VERSION=\"0.3.8\" -DWEECHAT_LICENSE=\"GPL3\" -MT wee-log.o
> -MD -MP -MF .deps/wee-log.Tpo -c -o wee-log.o wee-log.c
> wee-log.c: In function `log_printf':
> wee-log.c:136: parse error before `argptr'
> wee-log.c:136: `vaa_size' undeclared (first use in this function)
> wee-log.c:136: (Each undeclared identifier is reported only once
> wee-log.c:136: for each function it appears in.)
> wee-log.c:136: `vbuffer' undeclared (first use in this function)
> wee-log.c:136: `argptr' undeclared (first use in this function)
> wee-log.c:136: `vaa_num' undeclared (first use in this function)
> wee-log.c:136: `vaa_buffer2' undeclared (first use in this function)
> wee-log.c:129: warning: `ptr_buffer' might be used uninitialized in
> this function
> make[3]: *** [wee-log.o] Error 1
> make[3]: Leaving directory `/home/n/netllama/foo/weechat-0.3.8/src/core'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/home/n/netllama/foo/weechat-0.3.8/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/n/netllama/foo/weechat-0.3.8'
> make: *** [all] Error 2
> #########
> 
> This isn't my system, so I can't upgrade anything easily.  Is there a
> way to get this to build?
> 
> thanks!
> 
> -- 
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> L. Friedman                                    address@hidden
> LlamaLand                       https://netllama.linux-sxs.org
> 
> _______________________________________________
> Weechat-support mailing list
> address@hidden
> https://lists.nongnu.org/mailman/listinfo/weechat-support

Hi,

gcc 2.96 was released in 2000... so 12 years ago!
WeeChat will not compile with so old compiler, I'm sorry.
You have to upgrade your gcc and build tools to compile WeeChat.
By the way, I'm not sure about the min gcc you should have, I did not
test with very old versions.

-- 
Cordialement / Best regards
S├ębastien.

web: flashtux.org / weechat.org      mail: address@hidden
irc: FlashCode @ irc.freenode.net    xmpp: address@hidden

Attachment: signature.asc
Description: Digital signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]