[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[wdiff-bugs] [bug-wdiff] wdiff-1.0.2 test 3 (pager) failures

From: Nelson H. F. Beebe
Subject: [wdiff-bugs] [bug-wdiff] wdiff-1.0.2 test 3 (pager) failures
Date: Fri, 11 Nov 2011 11:36:08 -0700 (MST)

I've been investigating the several failures of test 3 (pager)
with wdiff-1.0.2 builds.

On Solaris 11, and several other systems, I got a single
failure reported:

  3: use pager                                       FAILED (wdiff.at:193)

Examination of the tests/testsuite.log file showed that the
lines differed: one had CR LF terminators, and the other LF

I switched from tcsh to ksh, and reran the tests, and the
same failure occurred.  Then I switched to bash, and the
tests passed.  No recompilation was done in those experiments.
I therefore concluded that the failure is some minor shell
issue, and installed wdiff-1.0.2 on that system.

The same procedure got the tests to pass on Solaris 10 x86.

On Mac OS X 10.5.8 PowerPC and x86_64, the same test fails, but for a
different reason, and switching shells does not get a successful test:

           3: wdiff.at:168       use pager

        ## ---------------------- ##
        ## Detailed failed tests. ##
        ## ---------------------- ##

        #                             -*- compilation -*-
        3. wdiff.at:168: testing use pager ...
        ./wdiff.at:184: screen -D -m -L \
        env PAGER="$PWD/dummypager" TERM=dumb LC_ALL=C LANGUAGE=C \
        wdiff -wW -xX -yY -zZ -a foo.txt bar.txt
        ./wdiff.at:193: sed 's/^ager/Pager/;s/\r//g;' screenlog.0
        --- -   2011-11-11 11:07:35.275049000 -0700
        +++ /local/build/cc/wdiff-1.0.2/tests/testsuite.dir/at-groups/3/stdout  
2011-11-11 11:07:35.000000000 -0700
        @@ -1,4 +1,2 @@
        -Pager starting.
        -Pager line start WfooX YbarZ end printed.
        -Pager now done.
        +env: wdiff: No such file or directory

        > env: wdiff: No such file or directory^M
        3. wdiff.at:168: 3. use pager (wdiff.at:168): FAILED (wdiff.at:193)

I then tried setting PATH to include the directory in which the new
wdiff executable is found, but that still did not work.  I installed
the build anyway.

On MirBSD, NetBSD, OpenBSD, and Fedora 15 (all x86), the third test
fails with this error:

        testsuite: error: cannot find screen

I ran "yum install screen" on the Fedora system, and then got
wdiff-1.0.2 tests to pass.

I have not yet been successful in building screen on the three BSD

Can the tests be done without having the screen utility available?

- Nelson H. F. Beebe                    Tel: +1 801 581 5254                  -
- University of Utah                    FAX: +1 801 581 4148                  -
- Department of Mathematics, 110 LCB    Internet e-mail: address@hidden  -
- 155 S 1400 E RM 233                       address@hidden  address@hidden -
- Salt Lake City, UT 84112-0090, USA    URL: http://www.math.utah.edu/~beebe/ -

reply via email to

[Prev in Thread] Current Thread [Next in Thread]