[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compile of 9.8 failed

From: Chris Green
Subject: Re: compile of 9.8 failed
Date: Wed, 4 Jan 2023 11:22:36 +0000

On Wed, Jan 04, 2023 at 11:15:24AM +0100, joerg van den hoff wrote:
> happy long time vile user here: I have used vile for a long time under 
> OSX and compiles always "just 
> worked".
> now, I have tried to compile it under OpenSuse linux on an old laptop I 
> have started playing around 
> with, but no luck. I get lot's of
> undefined reference to `tputs'
> and similar errors (referring to `tgoto', `tgetent', `tgetflag', `tgenum' 
> etc.) and compile fails. 
> the executed `./configure' run did not show any obvious problems.
> since I am a) totally new to OpenSuse and b) not into C programming I am 
> at a loss where to look to 
> find out which library or header file is missing (which I guess is the issue 
> here?). I guessed at 
> "termcap" and installed that package but that didn't help.
> any advice would be appreciated :).
The way I do it on Linux is to install the libncurses-dev package and
then './configure --with-ncurses'.

Chris Green

reply via email to

[Prev in Thread] Current Thread [Next in Thread]