[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: version dired-do-rename on remote dir becomes a copy

From: Michael Albinus
Subject: Re: version dired-do-rename on remote dir becomes a copy
Date: Fri, 18 Jan 2019 00:38:33 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Peter Mao <address@hidden> writes:

Hi Peter,

> On setup #2, accessing a remote directory, when I rename a
> subdirectory, it takes a long time because the move turns into a copy
> command, which takes a long time (for large directories).  This is
> true whether I use 'scp', 'ssh', or '-' (which is scp) as the
> connection method.
> I looked into the dired and wdired code between the two versions of
> emacs and found nothing substantially different between the versions.

This is <>. It is
solved for Emacs 26.2, currently under pretest.

It is solved also in Tramp 2.3.4, released last summer. If you don't
want to wait for Emacs 26.2, you could try this Tramp release.

> Also, possibly related, but not fully vetted, I find that a
> command-line rsync is much faster than copying directories using tramp
> (again, with method scp or ssh).

Have you tried Tramp's rsync method?

> Peter

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]