[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tinycc-devel] A possible bug in TCC

From: Michael Matz
Subject: Re: [Tinycc-devel] A possible bug in TCC
Date: Mon, 14 Dec 2020 15:56:44 +0100 (CET)
User-agent: Alpine 2.21 (LSU 202 2017-01-01)


On Sun, 13 Dec 2020, Anton Shepelev wrote:

Vincent Lefevre:

No issue with tcc 0.9.27+git20200814.62c30a4a-1 provided
by Debian.

The bug on my side is reproduced with this version just five
days old:


I had to compile it myself on Windows, using
win32\build-tcc.bat . Is there a pre-compiled win32 build

I have also tried the same on a Linux. Since I had not
enough permissions to install TCC, I only built it and tried
the following from the root of the source directory:

  ./tcc -Iinclude -L. ld.c

For uninstalled tcc you need to use './tcc -B. ...' to set the compiler path to something else than the install directory.

tcc failed with error:

  file '/usr/local/lib/tcc/libtcc1.a' not found

The file libtcc1.a is right there in the working directory.
Why did it ignore -L. ?

A deficiency. libtcc1.a is searched in a different way than normal -lfoo libraries.

FWIW, I also can't reproduce the problem you're seeing on linux x86-64, with various revisions of the mob branch.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]