[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tinycc-devel] Problem compiling for FreeBSD x86-64

From: Thomas Preud'homme
Subject: Re: [Tinycc-devel] Problem compiling for FreeBSD x86-64
Date: Wed, 11 Sep 2013 11:56:54 +0200
User-agent: KMail/4.10.5 (Linux/3.10-1-amd64; KDE/4.10.5; x86_64; ; )

Le mercredi 11 septembre 2013 09:09:28 Harshvardhan a écrit :
> Hello. I faced several problems compiling tcc-0.9.26 for FreeBSD x86-64,
> First of all it didn't detected that I am using x86-64 CPU and that
> FreeBSD don't use ldl. I manually edited Configuration script to change
> 'unknown' cpu to 'x86-64'.

Can you paste me the output of uname -m?

> Then I added FreeBSD in list of OS where
> there is noldl (like DragonflyBSD).

Already done on the mob branch (our development branch).


> Finally it got successfully compiled. Then I tried a simple program
> helloapp.c to test TCC:
> #include <stdio.h>
> int main(){
>          printf("Hello Earth! I am from Mars!");
>          return 0;
> }
> Then I got this error:
> address@hidden ~/Desktop% tcc helloapp.c
> In file included from helloapp.c:1:
> /usr/include/stdio.h:63: error: ';' expected (got "va_list")
> Sad. I checked /usr/include/stdio.h:63, it was "typedef __va_list
> va_list;". This is legal C I think.
> If you want to have look at modified Configure file, have a look here-
> http://pastebin.com/G65C7ASj
> So what is the problem? Why it isn't working?

I'm not sure. It reminds me of a passed bug but I can't recall what was the 
issue. Unfortunetely I can't reproduce this on Debian kFreeBSD machines and I 
don't have a FreeBSD machines at hand. Could you try if the problem is solved 
on the mob branch? you'll need to use git for that, see [0] for some info.

[0] http://repo.or.cz/w/tinycc.git

> -Regards,
>   Harshvardhan

Best regards,


Attachment: signature.asc
Description: This is a digitally signed message part.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]