[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Tinycc-devel] undefined symbols strlen and strcmp?

From: Stephan Beal
Subject: [Tinycc-devel] undefined symbols strlen and strcmp?
Date: Wed, 2 Feb 2011 07:36:20 +0100

Hi, all!

i'm trying something very simple:

address@hidden:~/cvs/fossil/cpdo$ tcc -fPIC -c  -DCPDO_ENABLE_SQLITE3=1 -DCPDO_ENABLE_MYSQL5=1  -I. -I./include  cpdo_amalgamation.c
address@hidden:~/cvs/fossil/cpdo$ tcc -c -I. -Iinclude test.c
address@hidden:~/cvs/fossil/cpdo$ tcc -o test-tcc -rdynamic -L/usr/lib/mysql -lmysqlclient -lsqlite3 cpdo_amalgamation.o test.o
tcc: undefined symbol 'strlen'
tcc: undefined symbol 'strcmp'

which special C libs do i need to specify here? i tried -ltcc, but that didn't help.

tcc 0.9.25 on x86/64 (Ubuntu 10.10 if it makes a difference)

i found this message in the list archives:


and it seems to be the same problem. i tried using the tcc version from git (current as of 3 minutes ago), but the same behaviour. (That message specifies a specific branch, but i am seeing only the master branch.)


----- stephan beal

reply via email to

[Prev in Thread] Current Thread [Next in Thread]