[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tinycc-devel] Unknown assembler directive '.lcomm'

From: Conrado Miranda
Subject: Re: [Tinycc-devel] Unknown assembler directive '.lcomm'
Date: Wed, 16 May 2007 11:07:11 -0300

Rob, I was wondering about what you said.
So I got the asm.c file at http://landley.net/code/tinycc/bugs . I tried to compile but I got an error: asm.c:5: unknown opcode 'xorl'.
Because of that, I tried to split the asm.c file (asm.c and asm.s), putting the funtion in a assembly file and compiling both with tcc. It worked as it should (as embedded asm compiled with gcc).
I haven't studied the code of tcc yet, so I can't help you providing bugs, but you said that "the assembler in tcc is pretty simple, and has some gaps". It isn't true, just with embedded asm. The tcc assembler work very well, as you can see if you try what I did :D
Cya man

(Sorry about the english =//)

On 5/16/07, Conrado Miranda <address@hidden> wrote:
Hum... OK
I'll check that later (maybe some other day).

On 5/16/07, Rob Landley <address@hidden > wrote:
On Tuesday 15 May 2007 11:39 pm, Conrado Miranda wrote:
> When I tried to compile this simple assembly file, I got this error:
> features.s:11: unknown assembler directive '.lcomm'
> I really don't know what is wrong, because it compile perfectly with
> GCC. Should I use some different type or it is really a bug?

The assembler in tcc is pretty simple, and has some gaps.  I've added this to
the list of things known not to work at http://landley.net/code/tinycc/bugs

Reducing the list of things known not to work starts to become a useful todo
item for somebody...

> Thanks.


Attachment: asm.c
Description: Text Data

Attachment: asm.s
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]