[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tinycc-devel] bounds checking bug?

From: Rob Landley
Subject: Re: [Tinycc-devel] bounds checking bug?
Date: Fri, 11 May 2007 22:54:16 -0400
User-agent: KMail/1.9.1

[ Apparently I left this message unsent when I suspended my laptop 
yesterday...  Might now be stale, dunno. ]

On Thursday 10 May 2007 2:28 pm, kf wrote:
> > Worked fine for me when I just tried it.
> So, no tcc's fault then?

Not solely our fault, but we may be partially responsible.  All I know is I 
just couldn't reproduce it, which means it's probably an interaction between 
tcc and something else.  (That something else is probably your glibc version 
doing the underlying malloc.)

I note that I tried my current hg snapshot rather than the last release 
version, but none of the changes that went in should have affected this...

> > > This GDB was configured as "i386-redhat-linux-gnu"...Using host
> > > libthread_db library "/lib/libthread_db.so.1".
> >
> > *shrug*  I haven't used windows in ages.
> ? I have never used windows.

Brain glitch.  (I was operating on three hours of sleep.)  I meant I haven't 
used _red_hat_ in ages.  (I was emailing somebody with a windows problem in 
another window, to which the answer was again the same.)

I can try a newer version of Ubuntu, I have a 7.04 installed in a qemu 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]