[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Texmacs-dev] Ctrl-x key binding seems not working

From: Miguel de Benito Delgado
Subject: Re: [Texmacs-dev] Ctrl-x key binding seems not working
Date: Wed, 4 Sep 2013 14:23:15 +0200


  this seems to be specific to Linux (haven't tested yet), because under MacOS 
I see the key presses being reported when I activate qt debugging (I just 
pushed some changes which should make the debugging output more manageable, 
btw.) I typed some text, then activated qt debugging and selected the text. 
This is the output on the console:

key  : 16777250
text : 
count: 0
key  : 88
text : 
count: 0
key press: C-x
key  : 72
text : h
count: 1
key press: h

Miguel de Benito.

On 4 Sep, 2013, at 11:14, Tian-Min Yan <address@hidden> wrote:

> Hi all,
> I found all key sequences with C-x *, mostly used in Emacs mode,  do not 
> work. I built the application with the latest svn version, but this problem 
> has existed for a long time since Qt version came to the mainstream. I am 
> wondering if other people have the similar trouble, it appears to me nobody 
> concerned about this issue before and I don't know if this problem is 
> specific to me. I am working on Ubuntu 13.04. The program was built with Qt 
> 4.8.4 and Guile 1.8.8.
> I tried to locate the problem. In the initialization part, the Scheme code 
> and main architecture (tm_config.cpp and edit_keyboard.cpp) work fine. All 
> shortcut sequences are enumerated properly, which are referred by 
> apply_wildcards (string s, hashmap<string,tree> w) without any problem.
> When I tried to type something, either the 'Ctrl' or 'x' is immediately 
> caught by the application. The problem occurs when I type their combination, 
> it seems QTMWidget::keyPressEvent (QKeyEvent* event) never catches the 
> Ctrl-x, 'QKeyEvent* event' does not report anything.
> In order to rule out the possible conflict between the system key binding and 
> TeXmacs, I built a Qt demo application to process keyboard event. Ctrl-x 
> works just fine. Now I have no idea why Ctrl-x just slips in TeXmacs for no 
> reason... I appreciate any help from you.
> PS. The funny thing was when I type 'C-x C-c', or 'C-x k', it really works to 
> close window.
> Best regards,
> Tian-Min
> _______________________________________________
> Texmacs-dev mailing list
> address@hidden
> https://lists.gnu.org/mailman/listinfo/texmacs-dev

reply via email to

[Prev in Thread] Current Thread [Next in Thread]