[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Texmacs-dev] Plugins TeXgraph and Eukleides

From: Offray Vladimir Luna Cárdenas
Subject: Re: [Texmacs-dev] Plugins TeXgraph and Eukleides
Date: Sun, 19 Apr 2009 09:09:17 -0500
User-agent: Thunderbird (X11/20090319)

Hi all,

Corcelle wrote:

No. I have a similar problem with Sage TeXmacs plugin, which I can solve exporting the $PATH variable to the place where Sage binary was located. I tried something similar with this two lines:

address@hidden ~]$ export TEXGRAPH_PATH=/usr/local/share/TeXgraph/
address@hidden ~]$ export $PATH=/usr/local/share/TeXgraph/

and I get:

bash: export: `/bin:/usr/bin:/sbin:/usr/sbin:/usr/bin/perlbin/site:/usr/bin/perlbin/vendor:/usr/bin/perlbin/core=/usr/local/share/TeXgraph/': not a valid identifier
The defaut installation in /usr/local/share/TeXgraph/ creates the startTeXgraph and CmdTeXgraph files in the /usr/local/bin directory which isn't known by your system.

There is a little error in your second line. For only one session, it should have been :
address@hidden ~]$ export PATH=$PATH:/usr/local/bin
So your PATH is now unreadable with the =.

To correct it try :
address@hidden ~]$ PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/bin/perlbin/site:/usr/bin/perlbin/vendor:/usr/bin/perlbin/core address@hidden ~]$ echo `export PATH=$PATH:/usr/local/bin` >> ~/.bashrc
if you use BASH shell

Thanks for your help. I tried yours and the Andreas method. None of them worked. Finally I made this:

export PATH=$PATH:/usr/local/share/TeXgraph/

Now I can launch TeXgraph from shell because the TeXgraph and TeXgraphCmd are now in my path. But I get a lot of message about the content of "/offray/macros" not being present and the TeXgraph GUI opens without any problem. I made a symlink from the macros directory to /home/offray and after that I didn't get any other message and TeXgraph is launching fine, but still I can't use TeXgraph inside TeXmacs.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]