[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[sysvinit-devel] halt problem

From: Ryan Meulenkamp
Subject: [sysvinit-devel] halt problem
Date: Wed, 3 Jan 2018 14:25:26 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.5.0

Hi y'all,

I ran into a problem using shutdown -h (or halt) on an openembedded-core (yocto) distro running on the Atmel at91sam9g45.

We used to run an openembedded-classic (angström) based OS with kernel version Here, halting the system would cause it to shutdown without reseting, or turning the power off, to await a manual reset.

Now we are building a new distro based on openembedded-core and yocto. Halting the system now causes a watchdog intervention. I tried all different arguments for both the shutdown and the halt command. It looks if though the classic based distro left the watchdog daemon running during a halt.

What could be the cause of this problem? In what direction should I look (e.g. kernel config, sysvinit config, openembedded config, processor specific code etc.)?

I'm not sure if this is the right mailing list to ask this question, but I guess one of you could point me in the right direction.

Thanks in advance and kind regards,

Ryan Meulenkamp

reply via email to

[Prev in Thread] Current Thread [Next in Thread]