[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Swftools-common] E-Paper Viewer with source for pdf2swf?

From: John Francis Lee
Subject: Re: [Swftools-common] E-Paper Viewer with source for pdf2swf?
Date: Sat, 18 Oct 2008 18:27:49 +0700
User-agent: Thunderbird (X11/20080925)

Matthias Kramm wrote:
On Sat, Oct 18, 2008 at 07:08:34AM +0700, John Francis Lee <address@hidden> 
If I go there I see a band of document icons across the top. Clicking on one of the icons brings me to a page with an empty frame with buttons across the top: "share this, send this, add to favorites..." and so on.

I see no way to "fix" this url so I can see it. Using a proxy makes no difference in either case, unless I first change the url as specified for youtube. And both sites show up in Opera.

Hm. It indeed *does* sound like your Firefox is broken. I guess you tried all the usual stuff, like re-installing Firefox,

 yeah, several times.

removing all settings (don't forget ~/.mozilla and ~/.firefox) etc.?

 I'll try that... Just
  rm -rf ~/.mozilla ~/.firefox

If you grab a swf file, place it on your local disk, generate a
html file like this
    swfdump -e file.swf -o file.html
and then open file.html in firefox, doesn't it work either?

Well, I tried that...

 address@hidden:~/tmp$ swfdump -e trigvisualizer.swf -o trigvisualizer.html
 Unknown option: -o

I thought maybe my swftools are too old

 address@hidden:~/tmp$ swfdump --version
 swfdump - part of swftools 0.8.1

So I tried downloading and making the l&g swftools

 address@hidden:~/Downloads/swftools-2008-10-17-2308$ make
 making all in m4...
 cd m4;make all
make[1]: Entering directory `/home/jfl/Downloads/swftools-2008-10-17-2308/m4' make[1]: Leaving directory `/home/jfl/Downloads/swftools-2008-10-17-2308/m4'
 making all in lib...
 cd lib;make all
make[1]: Entering directory `/home/jfl/Downloads/swftools-2008-10-17-2308/lib' gcc -c -DHAVE_CONFIG_H -I/usr/include/freetype2 -I/usr/include/fontconfig -I /usr/include/lame -fPIC -Wparentheses -Wimplicit -Wreturn-type -O -fomit-frame-pointer modules/swfabc.c -o modules/swfabc.o
 modules/swfabc.c:27:20: error: swfabc.h: No such file or directory
modules/swfabc.c:31: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
 modules/swfabc.c:37: error: expected ‘)’ before ‘*’ token
 modules/swfabc.c:43: error: expected ‘)’ before ‘*’ token
 modules/swfabc.c:50: error: expected ‘)’ before ‘*’ token

There's a setup.py file too. Playing with that I eventually tried

 address@hidden:~/swftools-2008-10-17-2308$ sudo python setup.py install
 Creating config.h...
 running install
 running bdist_egg
 running egg_info
 creating SWFTools.egg-info
 writing SWFTools.egg-info/PKG-INFO
 writing top-level names to SWFTools.egg-info/top_level.txt
 writing dependency_links to SWFTools.egg-info/dependency_links.txt
 writing manifest file 'SWFTools.egg-info/SOURCES.txt'
 reading manifest file 'SWFTools.egg-info/SOURCES.txt'
 writing manifest file 'SWFTools.egg-info/SOURCES.txt'
 installing library code to build/bdist.linux-i686/egg
 running install_lib
 running build_ext
 building 'SWF' extension
 creating build
 creating build/temp.linux-i686-2.5
 creating build/temp.linux-i686-2.5/lib
 creating build/temp.linux-i686-2.5/lib/python
 creating build/temp.linux-i686-2.5/lib/modules
 creating build/temp.linux-i686-2.5/lib/h.263
 creating build/temp.linux-i686-2.5/lib/action
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include -I/usr/include/freetype2 -I/usr/include/fontconfig -Ilib/lame/ -Ilib/pdf/xpdf -Ilib/pdf -I/usr/include/python2.5 -c lib/python/SWF.c -o build/temp.linux-i686-2.5/lib/python/SWF.o -fPIC -Wparentheses -Wimplicit -Wreturn-type -O3 -fomit-frame-pointer -Winline -Wno-unused -Wno-strict-prototypes -DHAVE_CONFIG_H -DSWFTOOLS_DATADIR="/usr/share/swftools/"
 In file included from lib/python/.././bitio.h:23,
                  from lib/python/../rfxswf.h:37,
                  from lib/python/SWF.c:25:
lib/python/.././types.h:42:2: error: #error "don't know how to define 16 bit integer"
 lib/python/.././types.h:62:2: error: #error "Unknown pointer size"
 error: command 'gcc' failed with exit status 1

So I'm at a loss as to the test

 swfdump -e file.swf -o file.html

Thanks for your help.

"This message may have been intercepted and read by U.S. government agencies including the FBI, CIA, and NSA without notice or warrant or knowledge of sender or recipient."

John Francis Lee
1025/37 Thanon Jet Yod
T.Wiang A.Mueang J.Chiangrai 57000

reply via email to

[Prev in Thread] Current Thread [Next in Thread]