[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [STUMP] More Crashes from Applications Other Than Gimp (OpenOffice

From: Egon Hyszczak
Subject: Re: [STUMP] More Crashes from Applications Other Than Gimp (OpenOffice Writer) (backtrace)
Date: Wed, 9 Sep 2009 03:50:03 +0000

Shawn, I made the change to clx.f in clisp-2.48 (line 8099), rebuilt, rebuilt stump... And things seem to be working great! I haven't tried very hard to get a crash, but I did start out by opening up three images in gimp and quitting immediately after. No crash. Normally I could get a hang/crash/freeze whatever you want to call it every time.

I also tried to reproduce the same issue with OpenOffice to no avail. Woohoo!

Thanks for your help, I've been afraid to really max out my hax0ring for fear of these unknown freezes. All seems to be well... for now...

So setting XWMHints to NULL allowed it to be null instead of freaking out and triggering the backtrace?

I have much to learn.


Hi Egon,

Thanks for the backtraces. They all seem to be croaking in a call to
XFree inside new-clx's wm-hints function. There is a path that leads
XFree to be called on an uninitialized variable that would cause this
crash. When you sent your first backtrace I tried to reproduce it but
failed. In the xorg's client library there is a single instance where
XGetWindowProperty will return without first setting prop_return to
NULL. wm-hints relies on prop_return being set to NULL and I believe
somehow you are finding a way to exercise the control path that leaves
prop_return untouched.

If my analysis is correct then the fix is really simple: initialize
the variable to NULL. Since I can't reproduce this can you see if this
fix will work for you? You'll need to build clisp from source. I'd
recommend grabbing the latest version of clisp, compiling it with the
new-clx module enabled, building stumpwm with it, and confirming that
you still get the crash bug. Then trying my fix.

Let me know if you need help building clisp.

To try my fix, open the file clisp-2.47/modules/clx/new-clx/clx.f and
change line 8097 from:

XWMHints *hints;


XWMHints *hints = NULL;

and rebuild.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]