[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Keybinding UTF-8 characters?

From: Stefan `Sec` Zehl
Subject: Keybinding UTF-8 characters?
Date: Tue, 26 Jun 2018 14:33:41 +0200
User-agent: Mutt/1.9.1 (2017-09-22)


I have the following lines in my .screenrc:

bind ! select 11
bind \" select 12
bind \$ select 14
bind % select 15
bind & select 16
bind / select 17
bind ( select 18
bind ) select 19
bind = select 10

The intention is to use ^a + SHIFT+number to switch to the ten next

This works fine with one problem. I'm on a german keyboard, and shift+3
produces § (the paragraph character) which ultimately is a two-byte

I tried several ways to bind it, but I could get none of them to work:

"bind" seems to insist on a single byte, so it complains about these:
bind § select 13
bind \§ select 13

this command is accepted (and afterwards shown in :help), but doesn't
actually work:
bind \247 select 13

I've also tried some bindkey variants, but they all seem to do nothing:

bindkey ^a§ select 13
bindkey ^a\247 select 13

Is there any way to achive what I want?

  1. Never challenge a sysadmin to do anything you don't actually want
  him or her to do.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]