[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Odd "backspace" behavior (SOLVED)

From: Dan Mahoney, System Admin
Subject: Odd "backspace" behavior (SOLVED)
Date: Sat, 30 May 2009 02:46:02 -0400 (EDT)
User-agent: Alpine 2.00 (BSF 1167 2008-08-23)


I had an issue a few months ago, I previously had the issue described here...

I traced it a bit more, and the multiple-of-8 issue (which I somehow recall being an issue on other systems) didn't seem to be the case.

What I eventually traced it down to was that I got very very odd behavior when doing funny shell things, specifically when running commands with %signs in them, and what it would seem was happening was those % signs were getting interpolated.

for example, the long command...

ls | grep "^qf" | xargs grep -c theirusername | cut -d : -f 1 | cut -c 3-20 | xargs -I % rm -v df% qf% | more

..really screwed up both cursor positioning and my prompt, and would do the same thing when I up-arrowed to it in my history.

So, my previous tcsh prompt was:

set prompt="%{\ek%}tcsh [$HOST] %{\e\\%}\%"

Once I switched over to

set prompt="%{\ektsch [$HOST]\e\\%}"\%

(that is, fit the entire prompt within a single escape-sequence bracket, even though the tcsh [$HOST] part are normal characters)

Everything started behaving.

Many thinks to Trent Buck for the direction. It got me most of the way there.


--------Dan Mahoney--------
Techie,  Sysadmin,  WebGeek
Gushi on efnet/undernet IRC
ICQ: 13735144   AIM: LarpGM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]