[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

screen's terminfo src is missing hpa= and vpa=...?

From: screen-users
Subject: screen's terminfo src is missing hpa= and vpa=...?
Date: Thu, 7 May 2009 17:51:57 -0700 (PDT)

Included with screen's source is the following file:


This file is the authoritative terminfo source for screen

I ask because it does not have entries for hpa or vpa, but
screen's man page indicates that maybe it should, specifically:

    ESC [ Pn G      Cursor horizontal position
    ESC [ Pn `      same as above
    ESC [ Pn d      Cursor vertical position

I would not have noticed (screen has always worked well) except
that I encountered a problem when running VMWare's python-based
installer while in a screen window.  The installer would silently
fail and the log would show this (from /var/log/vmware-installer):

  sys.stdout.write(curses.tparm(curses.tigetstr('hpa'), 0))
    TypeError: tparm() argument 1 must be string, not None

I think that's python-ese for your terminfo has no 'hpa'...

My underlying terminal is xterm-rxvt, which has these entries:

  hpa=\E[%i%p1%dG, vpa=\E[%i%p1%dd

I added the following to my local copy of the terminfo source
file for screen (not sure if this is right):

  hpa=\E[G, vpa=\E[d,

And then I used tic to update my terminfo DB and that fixed it...

I am wondering if the change I made should be included in
screen's source distribution, i.e. in here:


Is there some reason why that would be bad?  If so, what would be
the proper fix in this situation...?

Thanks in advance for your insights!

- Tor

reply via email to

[Prev in Thread] Current Thread [Next in Thread]