[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

screen command creates new window instead of new instance.

From: Chris Jones
Subject: screen command creates new window instead of new instance.
Date: Fri, 30 Jan 2009 23:46:19 -0500
User-agent: Mutt/1.5.13 (2006-08-11)

This left me speechless until I could figure out what was happening:

I was running a screen session started like so:

  $ screen -S xscrn

I wanted to test some prospective changes to my .screenrc, so from this
same screen session I started an xterm:

  $ xterm -tn "xterm-256color"

.. and proceeded to start a second screen instance on top of the xterm:

  $ screen -c .screenrc-manual

Well, nothing happened, at least that I could see .. I was back at my
bash prompt as if I had hit enter on an empty line.. no new screen
instance had been created:

  $ screen -ls
    There is a screen on:
          30228.xscrn     (Attached)
  1 Socket in /var/run/screen/S-gavron.

Unsure what to do next, I went to another xterm that had _not_ been
started from the xscrn screen session and typed the exact same command.

My "screen manual" started w/o any problem.

I was totally stumped.. then I took a closer look at my xscrn session..
and I noticed that it now had an additional window.

I ran the same scenario a few times and confirmed that contrary to what
I had expected, each time I ran "screen -c .screenrc-manual" from the
"child" xterm, it created an additional window in the "parent" screen
session instead of starting a new screen instance.

Trying to make sense of this unexpected scenario, I replaced:

  "screen -c .screen-manual" 

  "screen -S manual -c .screen-manual"

And this started a new screen session.

In case it matters:

  $ screen -v
  Screen version 4.00.03jw4 (FAU) 2-May-06

Is there something broken in my setup or is this the expected behavior?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]