[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

More Backspace Issues

From: Aaron Davies
Subject: More Backspace Issues
Date: Wed, 6 Sep 2006 09:30:55 -0400

Hi guys, I'm once again having odd backspace issues with screen.
They're slightly different from the ones I was having a few months
ago, so I'll once again submit them to the collective wisdom of this
list. The situation is as follows: I run a cygwin build of screen
(version 4.00.02) under PuTTYcyg (20060525 build). Within it, I run
zsh. From there, I ssh to a linux box, on which I again run zsh. On
that box, I start a screen session, which of course nests within the
local session on my windows box. Within that nested screen session,
ctrl-A <backspace> (typed as ctrl-A A <backspace>, of course) doesn't
work. The odd thing is, backspace works fine in other screen
contexts--on the ctrl-A : prompt, etc.--and in apps such as vi, emacs,
and so on. PuTTYcyg is set to send ^H for backspace, and that's what
^V <backspace> shows. /etc/screenrc *does* contain the line I was
advised to remove/undo in the previous email conversation (bindkey -d
-k kb stuff "\010"), but putting the suggested line (bindkey -d -k kb)
in ~/.screenrc only made things worse. Any ideas?
Aaron Davies

reply via email to

[Prev in Thread] Current Thread [Next in Thread]