[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-users] broken 'git clone ssh://

From: Bob Proulx
Subject: Re: [Savannah-users] broken 'git clone ssh://'
Date: Tue, 23 Feb 2016 15:25:33 -0700
User-agent: Mutt/1.5.24 (2015-08-30)

Andreas Schwab wrote:
> Pavel Raiskup <address@hidden> writes:
> > .. I'm unable to 'git clone git://' from savannah, ATM.  I tried several
> > packages, but unsuccessful.  It always goes like this:
> Anonymous access is probably limited to avoid too much load.

I wish I could say exactly what is happening but at this time I have
no reasonable findings.  I can only say that I was able to see the
same problem myself when testing it.  Problem confirmed.  But then
later it worked fine.  It isn't a hard repeatable failure.  It is
different on different invocations.

I can only suggest to keep retrying as it will eventually work.

The git-daemon is being invoked through a timeout wrapper script
invoked through the xinetd.  The xinetd is limited to 20 parallel
daemon processes for exactly the reason to avoid too much load.  It
used to be 40 parallel git-daemon processes but when Emacs converted
to git and all 40 slots were running it overloaded the system and it
would melt down.  Xinetd git-daemon maximum instances was reduced to
20 in order to reduce the level to something that the system could
reasonable handle.  It has been that way for the last year.  But the
failure of an immediate git clone failure does not match the behavior
that should be happening when max instances has been reached.  In that
case it should be paused waiting for a free slot (might eventually
time out if it goes too long) and not failing immediately.

And so the debugging continues in order to try to understand this


reply via email to

[Prev in Thread] Current Thread [Next in Thread]