savannah-register-public
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-register-public] [task #8406] Submission of MplayerGS


From: Yavor Doganov
Subject: Re: [Savannah-register-public] [task #8406] Submission of MplayerGS
Date: Sat, 02 Aug 2008 19:09:35 +0300
User-agent: Wanderlust/2.15.5 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/22.2 (i486-pc-linux-gnu) MULE/5.0 (SAKAKI)

Sylvain Beucler wrote:
> 
> > I'll post the proforma reply here for your approval.
> 
> Please do.

First, the main issue -- we do not recommend MPlayer, because at least
in the past it used to include some non-free codecs.  AFAICT, judging
by the Debian mplayer package, the only parts which are removed are
mencoder and dvdcss, which are free software but there are patent
concerns.  There are still binary codecs available to download from
their website, which is enough reason not to recommend it.

I'm not sure if this rules out MPlayer as dependency.

Provided that MPlayer is not a problem, here is the response I intend
to send:

* * *

I am reviewing your project -- sorry for the delay.
There are some inconsistencies:

  * Please remove all statements "All rights reserved." -- they are
    incompatible with the GPL and in general contradict with any free
    software license.
  * The preferred copyright notice for GPLv3 has changed slightly --
    please see http://www.gnu.org/licenses/gpl.html or the file
    COPYING in your tarball.
  * Please include a short README with a copyright notice in Resources
    for the images and the .gorm files.  See
    http://www.gnu.org/prep/maintain/html_node/Copyright-Notices.html
    for details.  (BTW, some of the images are executable -- perhaps a
    mistake.)
  * In MplayerGSInfo.plist the copyright year is 2003; since this is
    what the users will see in the Info dialog, please include all
    years as appropriate, separated by commas.  See the above URL for
    details.

Would you be willing to correct these small problems and give us the
URL to an updated tarball?

Thanks.

P.S.  Unrelated to the project registration, but I find it worth
mentioning.  Your package does not work on gNewSense 2.0 -- it builds
fine but NSException is thrown when loading the .gorms.  IIRC this is
because they were edited with a modern version of Gorm which depends
on GNUstep GUI 0.14.  You might want to include (in README, for
example) the minimal Base/GUI versions required; this would be very
helpful to your users.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]