[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[sr #110833] Pushing to Git not working but ssh connection works

From: Mohammad Akhlaghi
Subject: [sr #110833] Pushing to Git not working but ssh connection works
Date: Fri, 3 Feb 2023 10:07:31 -0500 (EST)


                 Summary: Pushing to Git not working but ssh connection works
                 Project: Savannah Administration
               Submitter: makhlaghi
               Submitted: Fri 03 Feb 2023 03:07:29 PM UTC
                Category: Source code repositories - developer access
                Priority: 5 - Normal
                Severity: 3 - Normal
                  Status: None
             Assigned to: None
        Originator Email:
        Operating System: GNU/Linux
             Open/Closed: Open
         Discussion Lock: Any


Follow-up Comments:

Date: Fri 03 Feb 2023 03:07:29 PM UTC By: Mohammad Akhlaghi <makhlaghi>
When I try to push commits in Gnuastro's 'master' branch, I get the following

$ $ git push origin master
fatal: remote error: access denied or repository not exported: /gnuastro.git

However, my SSH key is registered in "My Account Conf" (it was updated there
several weeks ago)! Therefore, I tried following the SshAccess
<> tip on debugging, but that
worked correctly:

$ ssh
The authenticity of host ' (' can't be
ED25519 key fingerprint is
This key is not known by any other names.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '' (ED25519) to the list of
known hosts.
Linux vcs1 4.9.0-19-amd64 #1 SMP Debian 4.9.320-2 (2022-06-30) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: DDD MMM  D HH:MM:SS YYYY from XX.XX.XX.XXX
You tried to execute: 
Sorry, you are not allowed to execute that command.
Connection to closed.

So apparently Savannah's CVS repository works with my SSH key, but not the Git
repository. I also tried the 'git push' command after the 'ssh' command above
(in case the problem was with my OS not recognizing Savannah).

For completeness, here is how Git recognizes Savannah on my system:

$ git remote -v
origin  git:// (fetch)
origin  git:// (push)

I would be grateful if you could help me find the solution to this problem.


Reply to this item at:


Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]