[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [sr #110155] Can not "git fetch upstream" public repos

From: zimoun
Subject: Re: [sr #110155] Can not "git fetch upstream" public repos
Date: Sat, 7 Dec 2019 12:25:45 +0100


Thank you for your time.

On Sat, 7 Dec 2019 at 04:06, Bob Proulx <address@hidden> wrote:

> zimoun wrote:
> > It works when cloning anonymously. I do not know yet when member
> > because my account is probably still too fresh.
> Member access for commit is always through ssh.  That's how we
> authenticate and authorized users.

I am lost. How can I get the member access for pulling through ssh?

I mean, I have an fresh account (since a couple of days) and I did
ssh-keygen and uploaded my public. Well, I have waited a couple of
hours (all the european night :-)) -- time for propagating as the doc
explains -- but it does still not work. What am I doing wrong?

--8<---------------cut here---------------start------------->8---
git clone ssh://address@hidden:/srv/git/guix/guix-artwork.git
Cloning into 'guix-artwork'...
ssh: connect to host port 22: Network is unreachable
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists
--8<---------------cut here---------------end--------------->8---

I have tried 'ssh -vvv address@hidden' and my keys are
apparently well found but the permissions are not set as I expect.

Other said, is it possible to clone/pull (read-only) through ssh
without write-access? Or is it possible to be member without
write-access to any group? I have read the doc and I am not sure to

> Anonymous access through https should be working, when it isn't
> "browned out" by a DDoS.

It works for my few tests. Hope that the DDoS is over.

Thank you in advance.

All the best,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]