[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Win 2019 to linux doesn't work

From: Harald Hannelius
Subject: Re: [rdiff-backup-users] Win 2019 to linux doesn't work
Date: Mon, 1 Apr 2019 08:02:38 +0300 (EEST)
User-agent: Alpine 2.11 (LNX 23 2013-08-11)

On Fri, 29 Mar 2019, Joe Steele wrote:

I don't have experience with your setup. Nonetheless, here are some things to check:

Check the linux server logs. Are there any messages about ssh connection attempts from the Windows client?

None, whatsoever. Not by using plink.exe or ssh.exe. If I run the ssh- or plink-commands by themselves the connection gets established.

Use tcpdump on linux (or maybe Wireshark on Windows) to see if a connection attempt is occurring.

Try adding the location of plink.exe to the Windows Path environment variable (but this shouldn't be necessary since it appears that you were invoking plink with the full path anyway.) To me, your error messages are consistent with rdiff-backup not being able to find and execute plink. Try intentionally misspelling plink when invoking rdiff-backup -- you likely will see the same error that you are currently getting.

You are right. Mis-spelling e.g. plinka.exe leads to the same error.

Try a test by removing the passphrase from your private key. It may be that plink is unable to access the terminal in order to prompt for a passphrase.

I don't have a passphrase on these keys.


Harald Hannelius | harald.hannelius/a\arcada.fi | +358 50 594 1020

reply via email to

[Prev in Thread] Current Thread [Next in Thread]