[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] rdiff-backup detects that many files has changed -

From: Attila Strba
Subject: [rdiff-backup-users] rdiff-backup detects that many files has changed - cifs mount
Date: Wed, 25 Jul 2012 17:53:06 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.6esrpre) Gecko/20120713 Thunderbird/10.0.6

Hi Guys,

I am having some trouble using rdiff-backup since I've migrated the backup scripts to a new CentOS 6.2 Server.
The backup scripts mounts several external remote server drives as CIFs:
mount -t cifs //$SERVER/$share -o username=${USERNAME},password=${PASSWORD} /mnt/$SERVER/$share
and does a backup on an external USB HDD:
rdiff-backup --print-statistics /mnt/$SERVER/$share /$TARGET/$SERVER/$share 2>&1

(I know, instead of mounting would be better to use the SSH copy feature of rdiff-backup, but that's how the scripts are and I don't want to install rdiff packages to the other servers.) The problem is that rdiff-backup detects many files as changed although they haven't changed at all.

--------------[ Session statistics ]--------------
StartTime 1343181615.00 (Wed Jul 25 04:00:15 2012)
EndTime 1343184940.73 (Wed Jul 25 04:55:40 2012)
ElapsedTime 3325.73 (55 minutes 25.73 seconds)
SourceFiles 41001
SourceFileSize 27002788885 (25.1 GB)
MirrorFiles 40998
MirrorFileSize 27002753521 (25.1 GB)
NewFiles 3
NewFileSize 35359 (34.5 KB)
DeletedFiles 0
DeletedFileSize 0 (0 bytes)
ChangedFiles 30930
ChangedSourceSize 13615555295 (12.7 GB)
ChangedMirrorSize 13615555290 (12.7 GB)
IncrementFiles 30933
IncrementFileSize 4792879 (4.57 MB)
TotalDestinationSizeChange 4828243 (4.60 MB)
Errors 0

I have tried to detect the file differences according the info from this mailing thread:
but was unable to find any differences from file_statistic, mirror_metadata or any ACL.

What I don't understand, why it worked on CentOS 5.x.

I am using these versions of the components:
librsync.i686                      0.9.7-2.el6.rf
rdiff-backup.i686               1.2.8-4.el6.rf
python.i686                           2.6.6-29.el6

I would appretiate any help or advice.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]