[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] IOError in backup.log

From: Bob Mead
Subject: Re: [rdiff-backup-users] IOError in backup.log
Date: Mon, 27 Oct 2008 09:11:22 -0700
User-agent: Thunderbird (X11/20080925)

Thanks for your reply. I've added the exclusions and -v 5 to my command
line as follows:

rdiff-backup -v 5 --force --print-statistics --include /etc --include
/home --include /var --include /root --exclude-sockets --exclude-fifos
--exclude-device-files --exclude / / root@<destination server
name>::/home/backups/<origin server name>
rdiff-backup --force --remove-older-than 2M root@<dest. svr.
name>::/home/backups/<origin server name>

When I call rdiff using this cmd, it locks up the destination server
(console showed 'BUG locked Processor 1 for 11s' messages). I tried
gunzip to look at the gzipped error log I mentioned in my last and it
failed with an 'unexpected end of file' message. I have not been able to
get anything out of twice running the altered command line (as above) -
i.e.-no files are output as a result of running the cmd.

This is output when I run the cmd on the originating server:

Executing ssh -C root@(dest. svr. name> rdiff-backup --server
Unable to import module xattr.
Extended attributes not supported on filesystem at /
ACLs not supported by filesystem at /
Detected abilities for source (read only) file system:
 Access control lists                         Off
 Extended attributes                          Off
 Mac OS X style resource forks                Off
 Mac OS X Finder information                  Off

Then it just hangs at the return prompt.



Andrew Ferguson wrote:

On Oct 14, 2008, at 10:52 AM, Bob Mead wrote:

Hi Andrew:
Thanks for your reply. I am aware of the incompatibility between versions. I've got 1.0.5 running on both ends (has to be - older Gentoo server is very fragile - no chance of upgrading).

Ok, good.

The traceback you posted shows that the error occurred while it was trying to read a certain file while copying it.

You should add the "-v 5" option to rdiff-backup. This will print more verbose logging messages, including each file it is working on while it is doing the backup. The last file it is trying to copy before the error message occurs is the file which is giving it problems. If we know which file it is, then we can diagnose further.

Also, are you using the --exclude-sockets --exclude-fifos and --exclude-device-files options? Those are probably good, since they tell rdiff-backup to skip certain special files which can be difficult to replicate and will generally be re-created by the OS or applications anyway.

What command line are you using to call rdiff-backup?

Lastly, to open a log file which ends with ".gz", use the 'gunzip' command to uncompress it. The 'tar' command is to open "TApe aRchives" (.tar). Many tar files are also compressed with gzip compression, making them ".tar.gz" ... the command to "tar xzf file.tar.gz" means to extract (x) and uncompress (z) the given file (f) -- it is equivalent to doing: 'gunzip file.tar.gz; tar xf file.tar". Tar files are a container format, gzip files are compressed. The Unix philosophy is to separate programs which perform distinct functions, so that the individual components can be re-used or mixed-and-matched. (ie, the compression and container).


Attachment: bmead.vcf
Description: Vcard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]