[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Exclude-sockets not working (Mac OS X)

From: Ilari Scheinin
Subject: Re: [rdiff-backup-users] Exclude-sockets not working (Mac OS X)
Date: Wed, 6 Jun 2007 12:51:32 +0300

I am running rdiff-backup with the --exclude-sockets option, but I am
still getting this kind of error for every socket:
ListError private/var/launchd/0/sock [Errno 1] Operation not
permitted: '/private/var/launchd/0/sock'

Good catch! If the user had extended attributes support enabled (as you
did), rdiff-backup tried to read/set the extended attributes on the
socket. However, sockets don't have extended attributes on Mac OS X or
Linux and this attempt generates an error. I have patched this in CVS
and the fix will be in the next release of rdiff-backup.

I believe that the same thing is still happening with fifos. I have -- exclude-fifos, but still get:

ListError private/var/spool/postfix/public/pickup [Errno 1] Operation not permitted: '/private/var/spool/postfix/public/pickup' ListError private/var/spool/postfix/public/qmgr [Errno 1] Operation not permitted: '/private/var/spool/postfix/public/qmgr'


reply via email to

[Prev in Thread] Current Thread [Next in Thread]