[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] AttributeError: 'module' object has no attribut

From: Gerard van Dijnsen
Subject: Re: [rdiff-backup-users] AttributeError: 'module' object has no attribute 'error_check_Main'
Date: Tue, 07 Feb 2006 09:27:25 +0100
User-agent: Mozilla Thunderbird 1.0.7 (X11/20051010)


I get this when ssh returns an unexpected output like a last login message or /etc/motd or something. Be sure to have the following in your /etc/sshd_config:

PrintMotd no
PrintLastLog no

Worked for me...

Felix Matschke wrote:

Dear all,

I would like to start rdiff-backup on my small debian/Mac OS X network (until now I used plain rsync). I installed rdiff-backup version 1.1.5 on both systems and there seems to be no problem (on debian via apt-get and on OS X Tiger via darwinports). From my OS X machine I can issue a command like

rdiff-backup address@hidden::/Users/me /home/me/Backup/me

without any problems. But I would like to use it as a cron job on the debian-server. Rsync worked just fine with a batch file like

    unset SSH_AUTH_SOCK
    eval `ssh-agent`
    ssh-add /home/me/.ssh/rsyncMe
    /usr/bin/rsync -avz address@hidden:/Users/me /home/me/Backup

but the seemingly equivalent batch file

    unset SSH_AUTH_SOCK
    eval `ssh-agent`
    ssh-add /home/me/.ssh/rsyncMe
    rdiff-backup address@hidden::/Users/me /home/me/Backup/me

gives me the following error message:

    Agent pid 8100
    Identity added: /home/me/.ssh/rsyncMe (/home/me/.ssh/rsyncMe)
    Traceback (most recent call last):
      File "/usr/bin/rdiff-backup", line 23, in ?
    AttributeError: 'module' object has no attribute 'error_check_Main'
Fatal Error: Truncated header string (problem probably originated remotely)

    Couldn't start up the remote connection by executing
ssh -C address@hidden rdiff-backup --server Remember that, under the default settings, rdiff-backup must be installed in the PATH on the remote system. See the man page for more information on this. This message may also be displayed if the remote version of rdiff-backup is quite different from the local version (1.1.5).


        ssh -C address@hidden rdiff-backup --server

results in the same error message.

Did anybody experience the same error message?


rdiff-backup-users mailing list at address@hidden
Wiki URL: http://rdiff-backup.solutionsfirst.com.au/index.php/RdiffBackupWiki

reply via email to

[Prev in Thread] Current Thread [Next in Thread]