[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] Serious data loss using rdiff-backup

From: Alistair Popple
Subject: [rdiff-backup-users] Serious data loss using rdiff-backup
Date: Sat, 18 Sep 2004 17:30:45 +1000


I seem to have found a rather serious bug somewhere in ridff-backup. 
I have been using it for almost three months now to do twice daily
(unattended) incremental backups from one server onto a backup server
(using the command "rdiff-backup -v5 --exclude /proc [remote
server]::/ /backup/[remote server name]").  This was working fine up
until a few days ago when I logged in to find /usr/bin, /usr/share and
/usr/lib to be missing (deleted) from the system.  At first I did not
suspect rdiff-backup, however reinstalling it and listing the
increments indicated a failed backup, so I ran "rdiff-backup -v5
--check-destination-dir /backup/[remote server name]".  This completed
successfully, however after this /usr/bin and /usr/lib (which had some
reinstalled programs in them) were again missing.  Doing this several
time had the same result.

As the system was such a mess I decided to reinstall everything. 
Previously we had been using Debian-3.0, however since then our client
has had several new servers put in, all running Gentoo, thus I
installed Gentoo.  After this had been completed I again had to check
the destination directory again as a remote backup failed.  Again
/usr/bin, /usr/lib and /usr/share had been deleted, this time using a
completely different distribution and in a completely different
environment (ie. no longer on the same network).  This was all done by
manually executing rdiff-backup (ie. not using automated scripts). 
Any help would be much appreciated as this seems to be a rather
serious problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]