[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 2/2] tests/bench: Rename test_akcipher_keys.inc -> test_akcipher_
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH 2/2] tests/bench: Rename test_akcipher_keys.inc -> test_akcipher_keys.c.inc |
Date: |
Tue, 10 Sep 2024 13:28:33 +0200 |
Since commit 139c1837db ("meson: rename included C source files
to .c.inc"), QEMU standard procedure for included C files is to
use *.c.inc.
Besides, since commit 6a0057aa22 ("docs/devel: make a statement
about includes") this is documented in the Coding Style:
If you do use template header files they should be named with
the ``.c.inc`` or ``.h.inc`` suffix to make it clear they are
being included for expansion.
Rename "test_akcipher_keys.inc" as "test_akcipher_keys.c.inc".
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
---
tests/bench/benchmark-crypto-akcipher.c | 2 +-
.../bench/{test_akcipher_keys.inc => test_akcipher_keys.c.inc} | 0
2 files changed, 1 insertion(+), 1 deletion(-)
rename tests/bench/{test_akcipher_keys.inc => test_akcipher_keys.c.inc} (100%)
diff --git a/tests/bench/benchmark-crypto-akcipher.c
b/tests/bench/benchmark-crypto-akcipher.c
index 5e68cb0a1c..fb88106a0c 100644
--- a/tests/bench/benchmark-crypto-akcipher.c
+++ b/tests/bench/benchmark-crypto-akcipher.c
@@ -16,7 +16,7 @@
#include "crypto/akcipher.h"
#include "standard-headers/linux/virtio_crypto.h"
-#include "test_akcipher_keys.inc"
+#include "test_akcipher_keys.c.inc"
static QCryptoAkCipher *create_rsa_akcipher(const uint8_t *priv_key,
size_t keylen,
diff --git a/tests/bench/test_akcipher_keys.inc
b/tests/bench/test_akcipher_keys.c.inc
similarity index 100%
rename from tests/bench/test_akcipher_keys.inc
rename to tests/bench/test_akcipher_keys.c.inc
--
2.45.2