[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-trivial] [Qemu-devel] [PATCH v1] configure: require glib-2.24

From: Peter Maydell
Subject: Re: [Qemu-trivial] [Qemu-devel] [PATCH v1] configure: require glib-2.24
Date: Thu, 26 Apr 2018 09:17:13 +0100

On 18 April 2018 at 15:44, Daniel P. Berrangé <address@hidden> wrote:
> On Wed, Apr 18, 2018 at 02:29:47PM +0100, Peter Maydell wrote:
>> Yes, my OSX build system is on glib 2.22. It's using 'fink' for 3rd
>> party library installations, and they somehow seem to have got stuck
>> on 2.22. Looking at the website the project seems to have basically
>> stagnated, and I guess I need to move to homebrew at some point
>> (likely after we get 2.12 out the door). But for the moment this
>> patch would break my pullrequest testing builds.
> Yeah that sounds reasonable as it would also align your build env with
> what we are testing via travis too.

I've now made the switch to homebrew, and so my OSX build tests
will be using glib 2.56. NB that this means that none of my merge
testing will catch "glib version too old" for our current setting
of "too old" -- I'm not sure what my current oldest version is in
the test machine set.

I've also upgraded Xcode, which means I now have a machine with
a clang that emits all the -Waddress-of-packed-member complaints.
I have configured the test build so those aren't fatal
(via --extra-cflags='-Werror -Wno-error=address-of-packed-member
-Wno-error=deprecated-declarations') but I'm now more interested in
getting those cleaned up so they don't clutter up my logfiles :-)

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]