[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-trivial] [Qemu-devel] [PATCH v1] configure: require glib-2.24

From: Markus Armbruster
Subject: Re: [Qemu-trivial] [Qemu-devel] [PATCH v1] configure: require glib-2.24
Date: Thu, 19 Apr 2018 09:19:28 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)

Daniel P. Berrangé <address@hidden> writes:

> On Wed, Apr 18, 2018 at 02:45:38PM +0200, Cornelia Huck wrote:
>> Are we ready to give up support for whatever distro is still on 2.22?
>> (If yes, can we bump to an even newer glib version?) Or should we
>> rather solve this by adding a g_realloc_n implementation for that case?
> Version 2.22 was released in Sep 2009, so coming up for 9 years old now.
> At some point we should to declare that platforms shipping >= NNN year
> old versions of software are not a desirable target for QEMU. What is
> our desired NNN value - 9 years feels awfully long to me.
> For libvirt we recently decided to become more aggressive[1] in culling old
> distros as supportable targets, declaring we'll only support non-EOL
> distros (for short life distros), or for long life distros (RHEL, LTS, etc)
> the most recent version, and the recent minus-1 for 2 years overlap.
> Should we formalize similar guidelines for QEMU to give developers a
> guide for when it is reasonable to increase the min required version of
> any 3rd party library ?  glib is a mandatory dep, but we've countless
> other optional libraries we might wish to increase min versions for too,
> and no guide on when it is reasonable todo so.

Yes, please.

> Regards,
> Daniel
> [1]   https://libvirt.org/platforms.html

This policy looks sensible to me

reply via email to

[Prev in Thread] Current Thread [Next in Thread]