[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Potential bug in user mode networking with QEMU 7.0 under Mac OS X

From: Mark Fonnemann
Subject: Re: Potential bug in user mode networking with QEMU 7.0 under Mac OS X
Date: Fri, 17 Jun 2022 16:20:30 -0400

I am able to reproduce the issue using Ubuntu 18.04 host as well.

I’d file this in the bug tracker but I want to make sure I’m not missing something obvious. Any suggestions?

Please advise.

On Jun 17, 2022, at 16:16, Mark Fonnemann <markf78@yahoo.com> wrote:


 I may have found a bug in Qemu-7.0’s user-mode networking under Mac OS X (installed with home-brew).

I first tried installing Windows 95 but I could not get a DHCP provided address: https://stackoverflow.com/questions/72538790/unable-to-get-user-mode-networking-in-qemu-working . 

I next tried doing a static IP address of and gateway of with dns and it did not work either.

I finally tried installing Slackware 12.2 and also did not receive a network address: dhclient -1 returns the message “no broadcast interfaces found - exiting”. I am also getting the message "qemu-system-i386: Slirp: Failed to send packet, ret: -1” in my Mac OS X terminal window.

Here’s my virtual machine configuration:

mfonnemann@Marks-MBP % qemu-system-i386 -nic user,model=ne2k_isa -hda linux.qcow2 -device sb16 -m 256 -cpu pentium -vga cirrus -soundhw pcspk -drive media=cdrom,file=/Users/mfonnemann/Downloads/slackware-12.2-install-d1.iso -boot menu=on
qemu-system-i386: warning: '-soundhw pcspk' is deprecated, please set a backend using '-machine pcspk-audiodev=<name>' instead

Any suggestions?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]