[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 3/3] migration: Rename res_{postcopy,precopy}_only

From: Juan Quintela
Subject: Re: [PATCH v2 3/3] migration: Rename res_{postcopy,precopy}_only
Date: Wed, 15 Feb 2023 19:15:01 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.2 (gnu/linux)

Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru> wrote:
> On 15.02.23 20:03, Juan Quintela wrote:
>> Once that res_compatible is removed, they don't make sense anymore.
>> We remove the _only preffix.  And to make things clearer we rename
>> them to must_precopy and can_postcopy.
>> Signed-off-by: Juan Quintela<quintela@redhat.com>
> Ideally headers of trace events (trace_vfio_state_pending, 
> trace_migrate_pending_estimate, trace_migrate_pending_exact)
> should be changed correspondingly.

They already use abrevs:

migrate_pending_estimate(uint64_t size, uint64_t pre, uint64_t post) "estimate 
pending size %" PRIu64 " (pre = %" PRIu64 " post=%" PRIu64 ")"

So I don't feel like doing bigger lines.

> with or without:
> Reviewed-by: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>


reply via email to

[Prev in Thread] Current Thread [Next in Thread]