[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v11 11/14] machine: Make smp_parse generic enough for all arc
From: |
Philippe Mathieu-Daudé |
Subject: |
Re: [PATCH v11 11/14] machine: Make smp_parse generic enough for all arches |
Date: |
Tue, 28 Sep 2021 12:57:21 +0200 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.1.0 |
On 9/28/21 05:57, Yanan Wang wrote:
> Currently the only difference between smp_parse and pc_smp_parse
> is the support of dies parameter and the related error reporting.
> With some arch compat variables like "bool dies_supported", we can
> make smp_parse generic enough for all arches and the PC specific
> one can be removed.
>
> Making smp_parse() generic enough can reduce code duplication and
> ease the code maintenance, and also allows extending the topology
> with more arch specific members (e.g., clusters) in the future.
>
> Suggested-by: Andrew Jones <drjones@redhat.com>
> Suggested-by: Daniel P. Berrange <berrange@redhat.com>
> Signed-off-by: Yanan Wang <wangyanan55@huawei.com>
> ---
> hw/core/machine.c | 91 +++++++++++++++++++++++++++++++++++----------
> hw/i386/pc.c | 84 +----------------------------------------
> include/hw/boards.h | 9 +++++
> 3 files changed, 81 insertions(+), 103 deletions(-)
> +/*
> + * smp_parse - Generic function used to parse the given SMP configuration
> + *
> + * Any missing parameter in "cpus/maxcpus/sockets/cores/threads" will be
> + * automatically computed based on the provided ones.
> + *
> + * In the calculation of omitted sockets/cores/threads: we prefer sockets
> + * over cores over threads before 6.2, while preferring cores over sockets
> + * over threads since 6.2.
> + *
> + * In the calculation of cpus/maxcpus: When both maxcpus and cpus are
> omitted,
> + * maxcpus will be computed from the given parameters and cpus will be set
> + * equal to maxcpus. When only one of maxcpus and cpus is given then the
> + * omitted one will be set to its given counterpart's value. Both maxcpus and
> + * cpus may be specified, but maxcpus must be equal to or greater than cpus.
> + *
> + * For compatibility, apart from the parameters that will be computed, newly
> + * introduced topology members which are likely to be target specific should
> + * be directly set as 1 if they are omitted (e.g. dies for PC since 4.1).
> + */
> static void smp_parse(MachineState *ms, SMPConfiguration *config, Error
> **errp)
Can we have it return a boolean instead?
- [PATCH v11 06/14] qtest/numa-test: Use detailed -smp CLIs in pc_dynamic_cpu_cfg, (continued)
[PATCH v11 10/14] machine: Tweak the order of topology members in struct CpuTopology, Yanan Wang, 2021/09/27
[PATCH v11 13/14] machine: Move smp_prefer_sockets to struct SMPCompatProps, Yanan Wang, 2021/09/27