qemu-s390x
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 02/13] linux-headers: update against 5.10-rc1


From: Alex Williamson
Subject: Re: [PATCH 02/13] linux-headers: update against 5.10-rc1
Date: Mon, 26 Oct 2020 11:37:16 -0600

On Mon, 26 Oct 2020 11:34:30 -0400
Matthew Rosato <mjrosato@linux.ibm.com> wrote:

> commit 3650b228f83adda7e5ee532e2b90429c03f7b9ec
> 
> Signed-off-by: Matthew Rosato <mjrosato@linux.ibm.com>
> ---
>  .../drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h | 14 ++--
>  .../infiniband/hw/vmw_pvrdma/pvrdma_verbs.h        |  2 +-
>  include/standard-headers/linux/ethtool.h           |  2 +
>  include/standard-headers/linux/fuse.h              | 50 +++++++++++++-
>  include/standard-headers/linux/input-event-codes.h |  4 ++
>  include/standard-headers/linux/pci_regs.h          |  6 +-
>  include/standard-headers/linux/virtio_fs.h         |  3 +
>  include/standard-headers/linux/virtio_gpu.h        | 19 ++++++
>  include/standard-headers/linux/virtio_mmio.h       | 11 +++
>  include/standard-headers/linux/virtio_pci.h        | 11 ++-
>  linux-headers/asm-arm64/kvm.h                      | 25 +++++++
>  linux-headers/asm-arm64/mman.h                     |  1 +
>  linux-headers/asm-generic/hugetlb_encode.h         |  1 +
>  linux-headers/asm-generic/unistd.h                 | 18 ++---
>  linux-headers/asm-mips/unistd_n32.h                |  1 +
>  linux-headers/asm-mips/unistd_n64.h                |  1 +
>  linux-headers/asm-mips/unistd_o32.h                |  1 +
>  linux-headers/asm-powerpc/unistd_32.h              |  1 +
>  linux-headers/asm-powerpc/unistd_64.h              |  1 +
>  linux-headers/asm-s390/unistd_32.h                 |  1 +
>  linux-headers/asm-s390/unistd_64.h                 |  1 +
>  linux-headers/asm-x86/kvm.h                        | 20 ++++++
>  linux-headers/asm-x86/unistd_32.h                  |  1 +
>  linux-headers/asm-x86/unistd_64.h                  |  1 +
>  linux-headers/asm-x86/unistd_x32.h                 |  1 +
>  linux-headers/linux/kvm.h                          | 19 ++++++
>  linux-headers/linux/mman.h                         |  1 +
>  linux-headers/linux/vfio.h                         | 29 +++++++-
>  linux-headers/linux/vfio_zdev.h                    | 78 
> ++++++++++++++++++++++
>  29 files changed, 301 insertions(+), 23 deletions(-)
>  create mode 100644 linux-headers/linux/vfio_zdev.h
> 
> diff --git 
> a/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h 
> b/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> index 7b4062a..acd4c83 100644
> --- a/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> +++ b/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> @@ -68,7 +68,7 @@ static inline int pvrdma_idx_valid(uint32_t idx, uint32_t 
> max_elems)
>  
>  static inline int32_t pvrdma_idx(int *var, uint32_t max_elems)
>  {
> -     const unsigned int idx = qatomic_read(var);
> +     const unsigned int idx = atomic_read(var);
>  
>       if (pvrdma_idx_valid(idx, max_elems))
>               return idx & (max_elems - 1);
> @@ -77,17 +77,17 @@ static inline int32_t pvrdma_idx(int *var, uint32_t 
> max_elems)
>  
>  static inline void pvrdma_idx_ring_inc(int *var, uint32_t max_elems)
>  {
> -     uint32_t idx = qatomic_read(var) + 1;   /* Increment. */
> +     uint32_t idx = atomic_read(var) + 1;    /* Increment. */
>  
>       idx &= (max_elems << 1) - 1;            /* Modulo size, flip gen. */
> -     qatomic_set(var, idx);
> +     atomic_set(var, idx);
>  }
>  
>  static inline int32_t pvrdma_idx_ring_has_space(const struct pvrdma_ring *r,
>                                             uint32_t max_elems, uint32_t 
> *out_tail)
>  {
> -     const uint32_t tail = qatomic_read(&r->prod_tail);
> -     const uint32_t head = qatomic_read(&r->cons_head);
> +     const uint32_t tail = atomic_read(&r->prod_tail);
> +     const uint32_t head = atomic_read(&r->cons_head);
>  
>       if (pvrdma_idx_valid(tail, max_elems) &&
>           pvrdma_idx_valid(head, max_elems)) {
> @@ -100,8 +100,8 @@ static inline int32_t pvrdma_idx_ring_has_space(const 
> struct pvrdma_ring *r,
>  static inline int32_t pvrdma_idx_ring_has_data(const struct pvrdma_ring *r,
>                                            uint32_t max_elems, uint32_t 
> *out_head)
>  {
> -     const uint32_t tail = qatomic_read(&r->prod_tail);
> -     const uint32_t head = qatomic_read(&r->cons_head);
> +     const uint32_t tail = atomic_read(&r->prod_tail);
> +     const uint32_t head = atomic_read(&r->cons_head);
>  
>       if (pvrdma_idx_valid(tail, max_elems) &&
>           pvrdma_idx_valid(head, max_elems)) {


The above is clearly just going to revert Stefan's changes to this file
via:

d73415a31547 )"qemu/atomic.h: rename atomic_ to qatomic_")

For now I'm just going to drop these changes (with comment) to avoid
that.  I'll leave it to others to fix the header update script to either
reimplement the s/atomic_/qatomic_/ conversion or remove these code
blocks altogether.  Sound ok?  Thanks,

Alex




reply via email to

[Prev in Thread] Current Thread [Next in Thread]