[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-ppc] [PATCH for-2.10 0/2] etsec: (TYPE_)ETSEC_COMMON macro cleanup

From: Eduardo Habkost
Subject: [Qemu-ppc] [PATCH for-2.10 0/2] etsec: (TYPE_)ETSEC_COMMON macro cleanup
Date: Fri, 31 Mar 2017 16:27:22 -0300

When working on other things, I got confused by the etsec code,
that didn't use the TYPE_ETSEC_COMMON macro in its type
declaration, and had no subclasses despite being named

This is a very simple cleanup to remove the _COMMON suffix from
the macros, and to use the TYPE_ETSEC macro when registering and
creating devices instead of hardcoding the "eTSEC" name.

Cc: Alexander Graf <address@hidden>
Cc: Scott Wood <address@hidden>
Cc: Jason Wang <address@hidden>
Cc: Fabien Chouteau <address@hidden>
Cc: address@hidden

Eduardo Habkost (2):
  etsec: Rename (TYPE_)ETSEC_COMMON to (TYPE_)ETSEC
  etsec: Use TYPE_ETSEC macro when registering/creating device

 hw/net/fsl_etsec/etsec.h |  6 +++---
 hw/net/fsl_etsec/etsec.c | 10 +++++-----
 hw/ppc/e500.c            |  4 ++--
 3 files changed, 10 insertions(+), 10 deletions(-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]