[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-ppc] [RFC 01/17] ppc: Remove some stub POWER6 models
From: |
David Gibson |
Subject: |
Re: [Qemu-ppc] [RFC 01/17] ppc: Remove some stub POWER6 models |
Date: |
Mon, 31 Oct 2016 19:37:04 +1100 |
User-agent: |
Mutt/1.7.1 (2016-10-04) |
On Mon, Oct 31, 2016 at 08:38:53AM +0100, Thomas Huth wrote:
> On 30.10.2016 12:11, David Gibson wrote:
> > The CPU model table includes stub (commented out) definitions for
> > CPU_POWERPC_POWER6_5 and CPU_POWERPC_POWER6A. These are not real cpu
> > models, but represent the POWER6 in some compatiblity modes. If we ever
> > do implement POWER6 (unlikely),
>
> I think we should finally add at least basic support for POWER6. It
> always confused me (from a user's point of view) that we have support
> for POWER5+ and POWER7, but not for POWER6.
I think it's just because at the time POWER6 was current, no-one was
working on qemu for Power. It'd be nice to have, but I don't know
that it's actually worth anyone's time to make happen.
> > we'll implement its compatibility modes in
> > a different way (similar to what we do for POWER7 and POWER8). So these
> > stub definitions can be removed.
> [...]
> > diff --git a/target-ppc/cpu-models.c b/target-ppc/cpu-models.c
> > index 901cf40..506dee1 100644
> > --- a/target-ppc/cpu-models.c
> > +++ b/target-ppc/cpu-models.c
> > @@ -1130,10 +1130,6 @@
> > #if defined(TODO)
> > POWERPC_DEF("POWER6", CPU_POWERPC_POWER6,
> > POWER6,
> > "POWER6")
> > - POWERPC_DEF("POWER6_5", CPU_POWERPC_POWER6_5,
> > POWER5,
> > - "POWER6 running in POWER5 mode")
> > - POWERPC_DEF("POWER6A", CPU_POWERPC_POWER6A,
> > POWER6,
> > - "POWER6A")
> > #endif
> > POWERPC_DEF("POWER7_v2.3", CPU_POWERPC_POWER7_v23,
> > POWER7,
> > "POWER7 v2.3")
> > diff --git a/target-ppc/cpu-models.h b/target-ppc/cpu-models.h
> > index 7d9e6a2..aafbbd7 100644
> > --- a/target-ppc/cpu-models.h
> > +++ b/target-ppc/cpu-models.h
> > @@ -549,8 +549,6 @@ enum {
> > CPU_POWERPC_POWER5 = 0x003A0203,
> > CPU_POWERPC_POWER5P_v21 = 0x003B0201,
> > CPU_POWERPC_POWER6 = 0x003E0000,
> > - CPU_POWERPC_POWER6_5 = 0x0F000001, /* POWER6 in POWER5 mode
> > */
> > - CPU_POWERPC_POWER6A = 0x0F000002,
> > CPU_POWERPC_POWER_SERVER_MASK = 0xFFFF0000,
> > CPU_POWERPC_POWER7_BASE = 0x003F0000,
> > CPU_POWERPC_POWER7_v23 = 0x003F0203,
>
>
> Patch looks good.
>
> Reviewed-by: Thomas Huth <address@hidden>
>
--
David Gibson | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_
| _way_ _around_!
http://www.ozlabs.org/~dgibson
signature.asc
Description: PGP signature
- [Qemu-ppc] [RFC 00/17] Clean up compatibility mode handling, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 02/17] powernv: CPU compatibility modes don't make sense for powernv, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 01/17] ppc: Remove some stub POWER6 models, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 14/17] pseries: Reset CPU compatibility mode, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 06/17] ppc: Rename cpu_version to compat_pvr, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 05/17] ppc: Clean up and QOMify hypercall emulation, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 08/17] ppc: Rewrite ppc_get_compat_smt_threads(), David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 12/17] ppc: Migrate compatibility mode, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 17/17] pseries: Default to POWER8 compatibility mode, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 16/17] ppc: Remove counter-productive "sanity checks" in migration, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 04/17] pseries: Make cpu_update during CAS unconditional, David Gibson, 2016/10/30
- [Qemu-ppc] [RFC 15/17] ppc: Check that CPU model stays consistent across migration, David Gibson, 2016/10/30