[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] Bug with smp ppc guest.

From: Alexander Graf
Subject: Re: [Qemu-ppc] Bug with smp ppc guest.
Date: Thu, 3 Apr 2014 20:26:25 +0200

On 03.04.2014, at 19:00, Frederic Konrad <address@hidden> wrote:

> On 03/04/2014 17:29, Andreas Färber wrote:
>> Hi Fred,
>> Am 03.04.2014 17:19, schrieb Frederic Konrad:
>>> I tried to boot a mpc85xx smp image with a new platform inside qemu.
>>> This command line reproduce the issue:
>>> ./ppc-softmmu/qemu-system-ppc -M mpc8544ds -kernel zImage --smp 2
>>> This use to work but since this commit:
>>> d197fdbc3b83655f3c145722805f0998c04dce16
>>> target-ppc: Reset SPRs on CPU reset
>>>     This resets SPR values to defaults on CPU reset. This should help
>>>     with little-endian guests reboot issues.
>>> I get some errors inside the guest:
>> Is this after today's fix?
>> http://git.qemu-project.org/?p=qemu.git;a=commit;h=87d8354de3560eb705bcee83142d775f703177a6
>> Regards,
>> Andreas
> Hi Andreas,
> I just tried seems it doesn't make any difference for me ;).

That patch should only have an effect when you're running with KVM which you 
probably don't :).

I can see the same breakage here, but only when my guest kernel is e500v2. With 
an e500mc kernel (even for -M mpc8544ds) it works fine. The secondary core also 
does get woken up. So it's probably something related to SPE emulation - hrm.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]