[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pci passhthrough device's pci mem cannot mapped

From: Peter Maydell
Subject: Re: pci passhthrough device's pci mem cannot mapped
Date: Tue, 31 Oct 2023 10:58:15 +0000

On Tue, 31 Oct 2023 at 06:51, Jiatong Shen <yshxxsjt715@gmail.com> wrote:
> Hello community experts,
>   I am using a 4.2.0 versioned qemu and passthrough an A40 (48G GPU memory). 
> When I start the virtual machine with following option "-m 
> size=4096M,slots=2,maxmem=1T ", the virtual machine could boot but the in the 
> VM I saw lspci failed to find bar1 and kernel message attached in the end of 
> the mail.

> I tried 6.2.0 with the same options and it works without problem. So my 
> question what might cause the problem and why. Thank you very much for help.

(I assume when you say "a 4.2.0 versioned qemu" you mean that
you're using version 4.2 of QEMU, not that you're using a
4.2-versioned machine type with a newer version of the QEMU
binary, given the command line that you say you're using.)

For problems of the form "this didn't work in QEMU version X,
but it does work in newer QEMU Y", the obvious guess is
"this was a bug, and we fixed it in the later version".
So if the newer version works for you I would recommend using
it -- 4.2 is now very old, and it's unlikely anybody will
be particularly interested in doing the work to try to figure
out what was going on in such an old version of QEMU, unless
you have a support contract with them...

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]