[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Wrong mouse movements virtualizing FreeBSD on Windows 11 with qemu-kvm

From: Mario Marietto
Subject: Wrong mouse movements virtualizing FreeBSD on Windows 11 with qemu-kvm
Date: Mon, 24 Jul 2023 19:13:16 +0200

Hello to everyone.

I would like to virtualize FreeBSD 13.2 on Windows 11 with qemu-kvm (for Windows) using the Hyper-V hypervisor (if I don't make a mistake it should be "-accel whpx").

These are the parameters that I'm using right now :

I:\OS\qemu\FreeBSD\qemu\qemu-system-x86_64w.exe -accel whpx -machine q35 \
-cpu kvm64,hv_relaxed,hv_time,hv_synic -m 8G \
-device vmware-svga,id=video0,vgamem_mb=16,bus=pcie.0,addr=0x1 \
-audiodev dsound,id=snd0 -device ich9-intel-hda \
-device hda-duplex,audiodev=snd0 \
-hda "I:\OS\ISO\FreeBSD\FreeBSD-13.2-RELEASE-amd64-disc1.iso" \
-hdb "I:\OS\qemu\FreeBSD\FreeBSD-ada1p2-qemu.img" -rtc base=localtime \
-device nec-usb-xhci,id=usb -device usb-tablet -device usb-kbd \
-smbios type=2 -nodefaults -netdev user,id=net0 \
-device virtio-net-pci,netdev=net0,id=net0,mac=52:54:00:11:22:33 \
-device ich9-ahci,id=sata \
-bios "I:\OS\qemu\FreeBSD\OSX-KVM-master\OVMF_combined.fd"

What's not working is the mouse. It does not move at all. I hoped to have found the solution in this post,but it still does not work :


one solution says :

you have to add a usb-device first

-device nec-usb-xhci,id=usb,bus=pci.0,addr=0x4 for usb 3.0 or

-device usb-ehci,id=usb,bus=pci.0,addr=0x4 for usb 2.

Then you can pass -device usb-tablet

ok,but none of those parameters are working in my case. And "-device usb-ehci,id=usb" does not work,either. Someone else suggested :

A workaround is to specify a usb tablet and use that as a mouse. Something similar to:

qemu-system-x86_64 -M pc ${otheroptions}                        \
     -drive if=none,id=usbstick,format=raw,file=/path/to/image   \
     -usb                                                         \ 
     -device usb-tablet,bus=usb-bus.0

When I click on the xfce desktop environment,it does not react. Even using sing virt-manager,I tried to remove :

<input type="mouse" bus="ps2"/>

it won't do this. The remove button is greyed out. I've also tried with "virsh edit FreeBSD-13.2" ; but it recreates the block of code every time I try to remove it.

2023-07-24 19 11 49.png
What can I do ?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]