[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: qemu and windows 11

From: Supratim Sanyal
Subject: Re: qemu and windows 11
Date: Fri, 15 Oct 2021 09:01:06 -0400

On 10/15/21 7:42 AM, Pascal wrote:

hi everyone,
here is the "environment" used (but it still doesn't work :-() :

off topic and irrelevant, but if your objective is to try Windoze 11, the insider preview works fine on Oracle Virtualbox which does not emulate TPM either.

Haven't tried qemu. Maybe try the preview and not the GA.

$ uname -r

$ /usr/bin/qemu-system-x86_64 -version
QEMU emulator version 6.1.0

$ qemu-img info 11.disk
image: 11.disk
file format: qcow2
virtual size: 64 GiB (68719476736 bytes)
disk size: 196 KiB
cluster_size: 65536
Format specific information:
    compat: 1.1
    compression type: zlib
    lazy refcounts: false
    refcount bits: 16
    corrupt: false
    extended l2: false

$ /usr/bin/qemu-system-x86_64 -accel kvm -machine q35 -m 4096 -device nec-usb-xhci -device usb-tablet -cpu host -parallel null -serial mon:stdio -bios /usr/share/edk2-ovmf/x64/OVMF.fd -hda 11.disk -cdrom 11.iso

(Shift F10)
> del appraiser.dll
> regedit.exe

new key Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\MoSetup
new dword32 Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\MoSetup\AllowUpgradesWithUnsupportedTPMOrCPU = 1

new key Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig
new dword32 Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig\BypassCPUCheck = 1
new dword32 Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig\BypassRAMCheck = 1
new dword32 Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig\BypassCPUCheck = 1
new dword32 Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig\BypassStorageCheck = 1
new dword32 Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig\BypassSecureBootCheck = 1

regards, lacsaP.

Le lun. 11 oct. 2021 à 10:48, Pascal <patatetom@gmail.com> a écrit :
hi everyone,
I'm trying in vain to install windows 11 in a virtual machine with qemu without tpm support with the various registry keys found on the internet (BypassTPMCheck for example) but I keep getting the message that my (virtual) machine does not have the necessary prerequisites and cetera : did any of you succeed in installing windows 11 without tpm ?
regards, lacsaP.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]