[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: qemu-system-sparc64 instruction set architecture compatibility

From: Mike Russo
Subject: Re: Fwd: qemu-system-sparc64 instruction set architecture compatibility (sparc v8+ vs sparc v9)
Date: Wed, 7 Apr 2021 12:25:48 +0000
User-agent: Evolution 3.38.1-1

Unfortunately you are out of luck right now.  This binary requires a an UltraSPARC processor to run on, because while it is only 32-bit, it contains instructions that can only be executed on an UltraSPARC (SPARCV8+/V9) processor.  While Solaris up to version 9 can run on the 32-bit sun4m architecture, it is only a SPARCV8 processor there.  So far, Solaris 32-bit or 64-bit cannot run properly on the sun4u architecture that has SPARCV8+/V9 support.  Some BSD and Linux can run on sun4u, BUT the binary you have is for Solaris (not sure which version) only.  The Niagara architecture support can run Solaris 10 with those instructions but hasn't been expanded much beyond that and also has no PCI bus support or network card support in it.  

Michael Russo | Systems Engineer | PaperSolve, Inc.
office (718) 477 8906    |    direct (332) 228 1817

Your random quote for today:
The more complex the mind, the greater the need for the simplicity of play.
		-- Kirk, "Shore Leave", stardate 3025.8

-----Original Message-----
From: CKIM <sgplap30@gmail.com>
To: qemu-discuss@nongnu.org
Cc: cheolyon38@naver.com
Subject: Fwd: qemu-system-sparc64 instruction set architecture compatibility (sparc v8+ vs sparc v9)
Date: Sun, 04 Apr 2021 20:11:00 +0800


Forwarding from qemu-devel@nongnu.org.

I'm not sure if this is right mailing list for this question but I
really appreciate if someone can answer to my question.

I have very old binary (testgen) which was built from old sparc station.
(no source code)

If I run "file testgen", I get the following.
ELF 32-bit MSB executable SPARC32PLUS Version 1, V8+ Required,
UltraSPARC1 Extensions Required, statically linked, not stripped

I want to run this binary from qemu as the sparc station (sun4u sparc
SUNW,Sun-Fire-V440) is very unstable.

Can QEMU (qemu-system-sparc64) support sparc32 application with v8+ ?

I tried to install a few packages listed at

I was able to install most of sun4m / sun4u guests listed in the wiki
and network setup was also ok but none of them could run the "testgen"

I always get "Cannot execute ELF binary" error message.

example with QEMU 5.2.0 version:
qemu-system-sparc64 -m 512 -drive
file=disk_image_netbsd64.raw,format=raw,index=0, \
-net nic,macaddr=52:54:00:fa:ce:10,model=e1000 \
-net tap -nographic \
-cdrom NetBSD-9.1-sparc64.iso \
-boot d

I found the cpu type is set "TI-UltraSparc-IIi" as default.

I couldn't find any option related to the instruction set architecture.
(qemu-system-sparc64 --help)

If I try the "niagara" machine example (OpenSPARCT1_Arch.1.5.tar.bz2), I

# isainfo -v
64-bit sparcv9 applications
32-bit sparc applications
asi_blk_init v8plus div32 mul32

It shows v8plus explicitly so I guess the niagara guest should be able
to run my "testgen" binary but I couldn't find any information about the
network setup for the OpenSPARCT1_Arch.1.5.tar.bz2. So I can't copy my
project files onto the guest machine.

My Sun physical server shows:
uname -a
SunOS sinuc035 5.8 Generic_117350-62 sun4u sparc SUNW,Sun-Fire-V440

I understand the sparc v7, v8, v8+, v9 are not chip architectures but
they are Instruction Set Architectures so I think the binary could run
on sun4u or sun4v, niagara ...

Can anyone know how to run the sparc32 v8+ binary from QEMU ?
Is it something the iso file need to be changed or qemu issue?

I appreciate if any useful info or hint. Thanks!

Best Regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]