[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Create Solaris 9/64bit Sparc VM using qemu-system-sparc64

From: Artyom Tarasenko
Subject: Re: Create Solaris 9/64bit Sparc VM using qemu-system-sparc64
Date: Mon, 22 Feb 2021 22:57:03 +0100

On Mon, Feb 22, 2021 at 9:43 PM Gong, Zaiwen <zgong@bnl.gov> wrote:


I have successfully installed a Solaris 9/32bit Sparc VM using qemu-system-sparc. 

Now I am trying to install a Solaris 9/64bit Sparc VM using qemu-system-sparc64. 

I tried with QEMU emulator version 4.2.0 and 5.2.0 (https://www.qemu.org/download/#source), but unfortunately, I failed in starting installation of Solaris 9/64 Sparc with QEMU. 

When I tried to boot the Solaris 9/64bit Sparc iso with this command:

#qemu-system-sparc64 -m 512 -hda sparc9.img -cdrom sol-9-905hw-ga-sparc-dvd.iso -prom-env 'auto-boot?=false'

I press enter, but nothing happened.

Can anyone confirm if Solaris 9/64bit Sparc is working with qemu-system-sparc64? Or maybe I used the wrong Solaris 9 iso?

As we discussed 3 Weeks ago [1], the sun4u target can not boot Solaris yet. The niagara target (64 bit) can boot the Solaris 10 image from the OpenSPARC project.
Solaris 9 can currently only be booted on sun4m (32 bit targets).


1. https://lists.nongnu.org/archive/html/qemu-discuss/2021-02/msg00010.html

reply via email to

[Prev in Thread] Current Thread [Next in Thread]