[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Strange behavior by qemu and the VM console.

From: George R Goffe
Subject: Strange behavior by qemu and the VM console.
Date: Wed, 20 Jan 2021 19:45:50 +0000 (UTC)


This system is a Fedora Core 34 x86_64 (Rawhide) at "latest" upgrade levels.

qemu is: :qemu-5.2.0-4.fc34.x86_64

kernel is:  5.11.0-0.rc4.129.fc34.x86_64

I have had good success with qemu but since the more recent 5.10.x kernels, 
qemus VM console has been sized much larger than the physical screen which 
makes operations largely VERY difficult to accomplish. i.e., attempting to 
install of FC34 .iso produces a console about twice as big as the physical 
screen. All the buttons are at the lower right of the screen but most of the 
"important" things are on the upper left.

Here's my current and unchanged qemu start script. I have tried -nographic (no 
results, no console), -display curses , -display gtk (no change in behavior), 
-g (not supported for the host)... I have tried boot parameters "nomodeset" (my 
standard), and removing "nomodeset" with NO appreciable change in behavior.

This radical change in behavior has come about fairly recently (past 2 weeks).

I'm sure there's something I've done... possibly by system upgrades of packages 
but whatever it is is not at all obvious.

I'm stumped. Can  you folks help me please?

Best regards and STAY SAFE,


qemu-system-x86_64                                                           \
      -cdrom /isos/Fedora-Everything-netinst-x86_64-Rawhide-20210118.n.1.iso  \
      -name fc34v                                                             \
      -cpu host                                                               \
      -enable-kvm                                                             \
      -m 2g                                                                   \
      -smp 2                                                                  \
      -drive file=/export/home/var-lib-libvirt-images/fc34-bt.img,format=raw  \
      -trace file=/root/qemu-trace-events                                     \
      -boot menu=on,reboot-timeout=15

reply via email to

[Prev in Thread] Current Thread [Next in Thread]