[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

using qemu with macvtap inside a container

From: Roman Dodin
Subject: using qemu with macvtap inside a container
Date: Mon, 18 Jan 2021 17:44:42 +0100

Hello qemu users,
I am failing to make a qemu process running inside a docker container to make use of a macvtap device.

Here is the diagram of a setup that I have
My goal is to make qemu process running inside the container to use macvtap1 interface that is configured.

The macvtap1 interface that I have, is using the underlying /dev/tap2 interface. That I deducted by checking ifindex (2) of macvtap1 interface

I tried multiple approaches.
1) to open the device, obtain its fd and pass fd to the qemu:
-device e1000,netdev=p01,mac=9a:d2:fc:3b:d9:71,bus=pci.1,addr=0x2 -netdev tap,id=p01,fd=3

2) referring to "tap2" in ifname of netdev section:
-netdev tap,id=p01,ifname=tap2

None of those approaches worked. By "none of them" worked I mean that I don't see any packets when I sniff on "macvtap1" interface when I do a ping from the VM that is launched with qemu.

I appreciate any pointers or suggestions in further troubleshooting.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]