[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Sound error: Could not initialize DirectSoundCapture

From: Jakob Bohm
Subject: Re: Sound error: Could not initialize DirectSoundCapture
Date: Mon, 7 Dec 2020 15:57:33 +0100
User-agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:78.0) Gecko/20100101 Thunderbird/78.5.1

On 07/12/2020 15:13, Peter Maydell wrote:
On Mon, 7 Dec 2020 at 13:56, kazusanosuke_kaz
<kazusanosuke_kaz@yahoo.co.jp> wrote:
Hi, all!

I've just installed qemu to my PC, Windows 8.1(x64) with Core i5-4670 / MSI 
MS-7817(OnBoard Sound) / GeForce GT 640
Windows 98SE was successfully installed on qemu, but sound device doesn't work 

"C:\Program Files\qemu\qemu-system-i386.exe" -device sb16 -m 512 
dsound: Could not initialize DirectSoundCapture
dsound: Reason: No sound driver is available for use, or the given GUID is not 
a valid DirectSound device ID
(I don't use Windows, but here are some suggestions based on
reading the source code.)

Even though I choose another soundhw, the result is all the same
That's because this error message is not related to what sound
hardware is being given to the guest. It's the QEMU DirectSound
audio backend complaining that when it asked the host Windows
for a sound-input device (ie a microphone or similar) it got
an error back. (Specifically, the IDirectSoundCapture_Initialize()
call failed.) So the warnings are basically saying "sound input
to QEMU is not going to work", and they'll be printed for any
kind of sound hardware you give to the guest (sb16, ac97, ...).

That said, looking at the code I think that the DirectSound
backend attempts to continue even if audio input doesn't work.
So if you only care about audio output, in theory these warnings
should be harmless.

You could try some of the suggestions in this stack overflow
(effectively "plug in a microphone" or "enable some windows-internal
input device") to see if they help. If that makes the warnings
go away and also makes sound output start working, then there
might be a bug in the QEMU code that is supposed to handle
"input doesn't work but proceed with output anyway". If the
warnings go away but sound output still doesn't work, then
the output problem is not related to the warnings.
I sometimes use Windows, and the only time I tried a qemu on Windows,
I could not find any working sound option, and all the help and error
messages were useless, suggesting things that weren't explained, listing
options that didn't work etc.

Someone on the team needs to clean up sound support in the prebuilt
Windows binaries that are linked to from qemu.org.

Jakob Bohm, CIO, partner, WiseMo A/S. http://www.wisemo.com <http://www.wisemo.com> Transformervej 29, 2860 Soborg, Denmark. direct: +45 31 13 16 10 <call:+4531131610>
This message is only for its intended recipient, delete if misaddressed.
WiseMo - Remote Service Management for PCs, Phones and Embedded

reply via email to

[Prev in Thread] Current Thread [Next in Thread]