[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trouble connecting Windows 10 Host to PowerPC E500 QEMU Instance for Ser

From: David Seccareccia
Subject: Trouble connecting Windows 10 Host to PowerPC E500 QEMU Instance for Serial Communication
Date: Tue, 7 Jul 2020 14:48:32 -0400



I am using QEMU v4.2.0 on Windows 10 and I am trying to connect my PowerPC E500 emulation to my host via serial connection. When trying to enter characters into the QEMU terminal, I see that they are not taken in. The current command I use to launch QEMU is shown below:


C:/Program\ Files/qemu/qemu-system-ppc -cpu e500 -d guest_errors,unimp -M ppce500 -m 2G,slots=3,maxmem=4G -s -monitor stdio -qmp tcp:,server,nowait \

  -bios Executables/mRTOSKernel.elf \

  -device loader,file=Executables/Partition1.elf,addr=0x95000,force-raw=on \

  -device loader,file=Executables/Partition2.elf,addr=0x12B000,force-raw=on \

  -device loader,file=Executables/PartitionTestPrinter.elf,addr=0x1BB000,force-raw=on \

  -device loader,file=Executables/Partition1_Config.bin,addr=0x85000,force-raw=on \

  -device loader,file=Executables/Partition2_Config.bin,addr=0x11B000,force-raw=on \

  -device loader,file=Executables/PartitionTestPrinter_Config.bin,addr=0x1AB000,force-raw=on \

  -device loader,file=Executables/moduleConfig.bin,addr=0x55000,force-raw=on


I have tried the following flags to help resolve the issue:

1.       Using the “–serial stdio” flag

a.       According to the QEMU documentation, this does not work for Windows hosts

2.       Using the “–serial COMn” flag, where n was chosen to be 10

a.       The error “-serial COM10: could not connect serial device to character backend 'COM10'” is generated

3.       Opening a TCP socket to connect to the emulation. I was able to connect with TeraTerm however the characters were still not being registered

a.       Using -chardev socket,id=testComm,host=,port=5555,server,telnet -serial chardev: testComm -nographic

b.      Only using the –serial option to define a TCP port (i.e –serial tcp:,server)

4.       Given the issues with Windows, I tried launching QEMU in MinGW64

a.       Using same commands as in 3.a and 3.b, however characters were still not being received by the test

b.      Mapping the MinGW serial ports to the COM ports

                                                               i.      Using -serial /dev/ttyS9 and opening TeraTerm to COM10 (ttyS9 in MINGW64 maps to COM10)

1.       C:\Program Files\qemu\qemu-system-ppc.exe: -serial /??/COM10: could not connect serial device to character backend '/??/COM10'

                                                             ii.      Using -chardev tty,id=ttyS9,path=/dev/ttyS9 -serial ttyS9

1.       QEMU through error “C:\Program Files\qemu\qemu-system-ppc.exe: -chardev tty,id=ttyS9,path=/??/COM10: Failed CreateFile (123)”


Is there a configuration step I am missing that is causing the keyboard input to be ignored?



David Seccareccia

reply via email to

[Prev in Thread] Current Thread [Next in Thread]