[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Sam460Ex screen mode, audio and network

From: BALATON Zoltan
Subject: Re: Sam460Ex screen mode, audio and network
Date: Tue, 2 Jun 2020 19:35:45 +0200 (CEST)
User-agent: Alpine 2.22 (BSF 395 2020-01-19)

On Tue, 2 Jun 2020, Andrea Palmatè wrote:
Regard the resolution. I've seen if i call the video mode SM502 instead of
SiliconMotion 502 it doesn't show the 1366x762 resolution.. that's weird..

I don't know much about how this works but maybe it has to match the chip or monitor driver to show up? I think on AmigaOS these use SiliconMotion502 name instead of the short name.

In the meanwhile i've tried to add -device ES1370 but i get no audio at
all. I've also a lot of shared "memfd open() failed: Function not
implemented" errors on console

I get none of these problems on Linux. Maybe it's a problem with WSL? If you're on Windows why don't you try a native Windows build? The official QEMU download page seems to not have 5.0.0 build yet but there are some alternative builds on the emaculation.com forum which should work. For AmigaOS use the vanilla 5.0.0 build, ignore the patched screamer sound build which is only needed for MacOS on mac99. See:


Regard the video mode. I'm pretty sure that resolutions like 1366x768
should work but not unticking the "default" checkbox. They needs to be
created by Screenmode program. The strange thing is that during
installation i've created successfully the resolution (that however had
that problem). Now with the OS even if the resolution is created i have
1024x768 twice.

If you can compile QEMU sources you could try printing SM501_DC_PANEL_FB_WIDTH and SM501_DC_PANEL_FB_HEIGHT in sm501_disp_ctrl_write() in qemu/hw/display/sm501.c to see what resolution the guest programs the card. The high 16 bits are the value to check. Haven't tried with adding a mode but with unticking default and setting width these remained 1024x768. Your screen shot looks like the window is a bit smaller than 1366x768 but it's wide aspect not 4:3 so maybe it did change mode but not sure to what size and if that matches your resolution (looks like it doesn't that's why you get garbled output).

I've also a problem that host mouse pointer is shown. I've read that i
need to add a "tabled" device in the xml file. But where i have to create
that file? Keep in mind that i'm using Ubuntu on Windows 10 via WSL and not
an ubuntu machine

What you read is for vitual machines created via libvirt and probably using other OS than AmigaOS so does not apply to your case. You can add a tablet with -device usb-tablet (see -device help for all options) but I don't think AmigaOS has a tablet driver so likely it won't work so you can ignore that. If the build from emaculation.com did not fix this you may try adding -sdl instead to use the SDL graphics backend which works better for this, people had problem with the default gtk backend and mouse on the emaculation.com forum and recommended using -sdl instead.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]